Bug 1014835 - python-nova package does not require sufficient python-oslo-config version
python-nova package does not require sufficient python-oslo-config version
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-nova (Show other bugs)
unspecified
All Linux
unspecified Severity medium
: ---
: Havana
Assigned To: Xavier Queralt
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 17:43 EDT by Dan Smith
Modified: 2014-06-18 03:00 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-24 03:45:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Smith 2013-10-02 17:43:05 EDT
Description of problem:

Upgrading from grizzly to havana RDO packages will leave a nova-only node unable to start nova services due to an un-upgraded python-oslo-config package.

Version-Release number of selected component (if applicable):

python-nova-2013.2-0.19.b3.el6.noarch

How reproducible:

Always.

Steps to Reproduce:
1. Install rdo-release-grizzly
2. Install openstack-nova-{compute,conductor,scheduler,api}
3. Install rdo-release-havana
4. Upgrade python-nova
4. Try to start any of the nova services and see the following in the log or on the console:

[root@centos1 ~]# /usr/bin/nova-compute 
Traceback (most recent call last):
  File "/usr/bin/nova-compute", line 6, in <module>
    from nova.cmd.compute import main
  File "/usr/lib/python2.6/site-packages/nova/cmd/compute.py", line 27, in <module>
    from nova import config
  File "/usr/lib/python2.6/site-packages/nova/config.py", line 22, in <module>
    from nova.openstack.common.db.sqlalchemy import session as db_session
  File "/usr/lib/python2.6/site-packages/nova/openstack/common/db/sqlalchemy/session.py", line 279, in <module>
    deprecated_opts=[cfg.DeprecatedOpt('sql_connection',
AttributeError: 'module' object has no attribute 'DeprecatedOpt'


Actual results:

All nova services crash on startup until you upgrade python-oslo-config.

Expected results:

The python-oslo-config version required should be req'd by the nova packages so they don't crash.

Additional info:

Nova packages just require python-oslo-config, but without any version:

  [root@centos1 ~]# rpm -q --requires python-nova | grep oslo
  python-oslo-config

whereas other packages like cinder do this properly:

  [root@centos1 ~]# rpm -q --requires python-cinder | grep oslo
  python-oslo-config >= 1:1.2.0

Note You need to log in before you can comment on or make changes to this bug.