Bug 1014844 - Wireless fails to reconnect after sleep with kernel 3.11.x
Wireless fails to reconnect after sleep with kernel 3.11.x
Status: CLOSED DUPLICATE of bug 1010603
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 18:13 EDT by Paul Lipps
Modified: 2013-10-18 22:21 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 22:21:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages after failed resume (11.96 KB, text/plain)
2013-10-16 11:06 EDT, Niklas Doose
no flags Details

  None (edit)
Description Paul Lipps 2013-10-02 18:13:20 EDT
Description of problem:
Wireless fails to reconnect after sleep with kernel 3.11.x

Version-Release number of selected component (if applicable):
This only occurs with kernels 3.11.1 and 3.11.2 so far, falling back to any kernel prior to 3.11.1 solves the issue.

How reproducible:
Everytime

Steps to Reproduce:
1. Close lid to netbook that is connected to wifi, netbook sleeps.
2. Open lid to netbook and press spacebar, netbook wakes.


Actual results:
There is a red X where the wireless applet should be in KDE, clicking it reveals that all fields says 'unspecified'. Logout and back in does not resolve, system must be restarted.

Expected results:
Wireless reconnects without issue.

Additional info:
This is on an ASUS Eee PC 1000HE with a an Ralink RT2790 chipset.
Comment 1 Paul Lipps 2013-10-06 17:04:27 EDT
Confirmed issue is present with kernel 3.11.3 as well.

1) Wake from sleep
2) NetworkManager dies with a Red X in the system tray and will not connect.
3) Attempt to logout and/or restart fails
4) Cycle power to recover.
Comment 2 Niklas Doose 2013-10-09 09:13:05 EDT
I have the same problem, only difference is I use Gnome Shell. Networkmanager says "Not Managed" for wireless connections after resume from suspend.

Normal reboot, shutdown or logout is impossible, even switching to another tty is not working.

Hardware is a Lenovo G530 Laptop, Wifi is 

$ lspci -v | grep Wireless
04:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection

All 3.11.x Kernels in Fedora 19 so far resulted i this, the 3.10.x work!
Comment 3 Niklas Doose 2013-10-14 11:58:10 EDT
The issue is still present for me with kernel 3.11.4.

It might also be connected to a systemd error, for me after failing to resume properly journalctl gives error:

Okt 14 17:45:11 niklas-laptop systemd-cgroups-agent[1876]: Failed to get D-Bus connection: Failed to connect to socket /org/freedesktop/systemd1/private: Connection refused

Is anybody reading this? What information should be provided to help solving the issue?
Comment 4 Paul Lipps 2013-10-15 16:48:49 EDT
Seems the problem is resolved for me on kernel 3.11.4-201.

I'd like to say thanks for all the feedback and support from all the devs. It makes me glad that I go out of my way to file bug reports.
Comment 5 Michele Baldessari 2013-10-15 17:59:32 EDT
Niklas,

do you have a full /var/log/messages after you hit this issue?

thanks,
Michele
Comment 6 Michele Baldessari 2013-10-15 18:04:23 EDT
(note that this issue might be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1010603)
Comment 7 Niklas Doose 2013-10-16 11:06:06 EDT
Created attachment 812993 [details]
/var/log/messages after failed resume

This is my /var/log/messages file after trying to resume with kernel 3.11.4.

I assume that the systemd error actually means that my issue is actually realted to the other bug you mentioned, Michele!
Comment 8 Michele Baldessari 2013-10-16 14:45:45 EDT
Thanks Niklas.

Yes definitely a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1010603

Paul, Niklas can you close this one as duplicate of the above?

thanks,
Michele
Comment 9 Niklas Doose 2013-10-17 08:00:01 EDT
Thanks for helping, Michele.

I think I cannot close this bug because I am not the original reporter.

Greetings, Nikas
Comment 10 Paul Lipps 2013-10-18 22:21:12 EDT

*** This bug has been marked as a duplicate of bug 1010603 ***

Note You need to log in before you can comment on or make changes to this bug.