Bug 1014857 - [Broadcom 6.4 but] Writes to multipath FC disk resulted in 'Operation not permitted' during link toggle test
[Broadcom 6.4 but] Writes to multipath FC disk resulted in 'Operation not per...
Status: CLOSED DUPLICATE of bug 958091
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
6.4
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Ben Marzinski
Red Hat Kernel QE team
:
Depends On:
Blocks: 917159
  Show dependency treegraph
 
Reported: 2013-10-02 19:35 EDT by Eddie Wai
Modified: 2015-10-14 12:17 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-14 12:17:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
multipathd log which contains the 'DISK_RO=1' message (9.90 MB, application/zip)
2013-10-02 19:40 EDT, Eddie Wai
no flags Details
corresponding message log (12.75 MB, text/plain)
2013-10-02 19:41 EDT, Eddie Wai
no flags Details
Application error log with 'Operation not permitted' (8.17 KB, text/plain)
2013-10-02 19:42 EDT, Eddie Wai
no flags Details

  None (edit)
Description Eddie Wai 2013-10-02 19:35:51 EDT
Description of problem:
In the midst of removing and re-establishing multipath FC disks (via FCoE), the multipathd daemon marked the disk to read-only (DISK_RO=1) for an extended period of time which led to 'Operation not permitted' failures in the disk-write application.  Note that for this specific case, the link toggle was caused by the HP interconnect reboot test.

Version-Release number of selected component (if applicable):
This was observed with the device-mapper-multipath under RHEL6.4 GA

How reproducible:
Reproducible after 3-4 hours of testing

Steps to Reproduce:
1. Establish FCoE disks with multipath
2. Continuously do write I/Os to the disks
3. toggle remote FC links

Actual results:
After a few hours of testing, the test application will fail with the 'Operation not permitted' message for the failed write command due to the disk being marked RO.

Expected results:
In this multipath environment, there's always a path to the FC disk.  So for every link toggle event, the multipathd daemon should be able to react and change the path accordingly.

Additional info:
Comment 1 Eddie Wai 2013-10-02 19:40:54 EDT
Created attachment 806809 [details]
multipathd log which contains the 'DISK_RO=1' message
Comment 2 Eddie Wai 2013-10-02 19:41:44 EDT
Created attachment 806810 [details]
corresponding message log
Comment 3 Eddie Wai 2013-10-02 19:42:29 EDT
Created attachment 806811 [details]
Application error log with 'Operation not permitted'
Comment 5 Ben Marzinski 2013-10-03 12:47:10 EDT
This looks like it might be a dup of Bug #958091.  The issue is that whenever multipath fails reloading a table, it retried read-only. In case a device was read-only.  The fix for Bug #958091, was to only try this reload if the table-load failed with an error of EROFS.  Can you please try the latest packages (device-mapper-multipath-0.4.9-71.el6) available at:

http://people.redhat.com/bmarzins/device-mapper-multipath/rpms/RHEL6/x86_64/

and

http://people.redhat.com/bmarzins/device-mapper-multipath/rpms/RHEL6/i686/

and let me know if this resolves the issue.
Comment 6 Eddie Wai 2013-10-09 13:51:29 EDT
Thanks, Ben.  We are still working to verify your patch.  I'll be sure to keep you posted on our findings.
Comment 7 RHEL Product and Program Management 2013-10-13 21:48:24 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 Ben Marzinski 2015-10-14 12:17:06 EDT
I'm pretty sure this is a dup, as mentioned in Comment 5.  It's been two years, with no response from the reporter on verifying this, so I'm closing the bug.

*** This bug has been marked as a duplicate of bug 958091 ***

Note You need to log in before you can comment on or make changes to this bug.