Bug 1014873 - Change 'rhc domain setup' to 'rhc setup'
Change 'rhc domain setup' to 'rhc setup'
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 20:52 EDT by brice
Modified: 2015-07-28 21:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-28 21:35:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brice 2013-10-02 20:52:16 EDT
Description of problem:

Running the $rhc domain --help command lists the available options for $rhc domain <action>. It says that status is deprecated, and to use 'setup' instead.

This should probably read: use 'rhc setup' instead.

This is because, as it stands, the user would be running the command 
$rhc domain setup as this is what it is implying. 


Version-Release number of selected component (if applicable):


How reproducible:

every time

Steps to Reproduce:
1. run $rhc domain --help
2. look at what it says after the 'status' option.
3.

Actual results:
status    DEPRECATED use 'setup' instead

Expected results:
status    DEPRECATED use 'rhc setup' instead

Additional info:
Comment 1 brice 2013-10-08 20:35:50 EDT
Issue seems to be fixed with the new update (1.15). Problematic options have been removed form the --help command.

Note You need to log in before you can comment on or make changes to this bug.