Bug 1014899 - Command line support for filtering policy rules by user(s), group(s), self
Command line support for filtering policy rules by user(s), group(s), self
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
develop
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.15.2
: ---
Assigned To: Amit Saha
tools-bugs
: FutureFeature
: 1039478 (view as bug list)
Depends On: 1011378
Blocks: 1039478
  Show dependency treegraph
 
Reported: 2013-10-03 00:46 EDT by Amit Saha
Modified: 2015-07-26 18:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 02:04:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Saha 2013-10-03 00:46:52 EDT
Description of problem:

BZ#1011378 adds the support for retrieving access policy rules for a system. It will also be useful to be able to retrieve the policies for particular user(s), group(s)  and the user himself/herself.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

List my access rules for system test1.example.com:

$ bkr policy-list test1.example.com --mine

List a user's access rules for system test1.example.com:

$ bkr policy-list test1.example.com --user <username>

List a group's access rules for system test1.example.com:

$ bkr policy-list test1.example.com --group <groupname>


Additional info:

All three should be accessible to any authenticated user?
Comment 2 Amit Saha 2013-12-01 20:39:43 EST
On gerrit: http://gerrit.beaker-project.org/#/c/2573/1
Comment 4 Nick Coghlan 2013-12-09 02:15:32 EST
The updated documentation for this change is available at:

http://beaker-project.org/docs-release-0.15/man/
Comment 5 Amit Saha 2013-12-09 03:08:04 EST
For the  --mine filter, it should check if the user is authenticated. Currently this is not the case and results in:

"AttributeError: 'NoneType' object has no attribute 'user_name'"
Comment 6 Amit Saha 2013-12-09 03:31:48 EST
On gerrit: http://gerrit.beaker-project.org/#/c/2603/1
Comment 7 xjia 2013-12-09 04:06:04 EST
(In reply to Amit Saha from comment #5)
Have opened a bug for it : 
https://bugzilla.redhat.com/show_bug.cgi?id=1039478
Comment 8 Amit Saha 2013-12-09 19:59:31 EST
*** Bug 1039478 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.