Bug 1014900 - SSSD Package Dependencies Broken for F19 to Rawhide (& F20)
SSSD Package Dependencies Broken for F19 to Rawhide (& F20)
Status: CLOSED DUPLICATE of bug 1016402
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 00:48 EDT by sean_mccully
Modified: 2013-10-08 04:03 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 04:03:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean_mccully 2013-10-03 00:48:55 EDT
Description of problem:
Unable to update from F19 to RawHide/F20

Version-Release number of selected component (if applicable):
Fedora 19

How reproducible:
Everytime

Steps to Reproduce:
1. enable rawhide
2. update yum
3. Package Depends Broken

Actual results:
--> Finished Dependency Resolution
Error: Package: sssd-common-pac-1.11.1-1.fc19.x86_64 (@updates/19)
           Requires: sssd-common = 1.11.1-1.fc19
           Removing: sssd-common-1.11.1-1.fc19.x86_64 (@updates/19)
               sssd-common = 1.11.1-1.fc19
           Updated By: sssd-common-1.11.1-1.fc21.x86_64 (rawhide)
               sssd-common = 1.11.1-1.fc21
Error: Package: dnf-0.4.2-1.gitc1716d7.fc21.noarch (rawhide)
           Requires: python-libcomps = 0.1.3
           Installed: python-libcomps-0.1.4-1.fc21.x86_64 (@rawhide)
               python-libcomps = 0.1.4-1.fc21
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
packages

Additional info:
Comment 1 Ales Kozumplik 2013-10-03 02:14:59 EDT
(In reply to sean_mccully from comment #0)
> Error: Package: dnf-0.4.2-1.gitc1716d7.fc21.noarch (rawhide)
>            Requires: python-libcomps = 0.1.3
>            Installed: python-libcomps-0.1.4-1.fc21.x86_64 (@rawhide)
>                python-libcomps = 0.1.4-1.fc21

The latest rawhide build of DNF fixes this:

http://koji.fedoraproject.org/koji/buildinfo?buildID=468942
Comment 2 Jan Zeleny 2013-10-03 03:14:37 EDT
And the rest is a problem (if it even is a problem) of sssd, yum just reports it. Reassigning for further evaluation.
Comment 3 Marcel Ribeiro Dantas 2013-10-08 01:07:09 EDT
I got a similar output in here:

Description of problem:
Unable to update from F19 to RawHide/F20

Version-Release number of selected component (if applicable):
Fedora 19

How reproducible:
Everytime

Steps to Reproduce:
sudo yum --releasever=20 distro-sync

Actual results:
--> Finished Dependency Resolution
Error: Package: sssd-common-pac-1.11.1-1.fc19.x86_64 (@updates/19)
           Requires: sssd-common = 1.11.1-1.fc19
           Removing: sssd-common-1.11.1-1.fc19.x86_64 (@updates/19)
               sssd-common = 1.11.1-1.fc19
           Desatualizado por: sssd-common-1.11.0-1.fc20.x86_64 (fedora)
               sssd-common = 1.11.0-1.fc20
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
packages
Comment 4 Jakub Hrozek 2013-10-08 04:03:28 EDT

*** This bug has been marked as a duplicate of bug 1016402 ***

Note You need to log in before you can comment on or make changes to this bug.