Bug 1014921 - Regression in CLI deployment archive introduced by bz991469
Regression in CLI deployment archive introduced by bz991469
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CLI (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER6
: EAP 6.2.0
Assigned To: Ivo Studensky
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 02:34 EDT by Ivo Studensky
Modified: 2014-06-17 04:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:19:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test CLI deployment archive (2.35 MB, application/zip)
2013-10-17 06:33 EDT, Petr Kremensky
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1913 Major Resolved CLI 'module add' command fail if a drive letter is specified in its resource path 2016-09-11 11:32 EDT

  None (edit)
Description Ivo Studensky 2013-10-03 02:34:56 EDT
Description of problem:
A regression has been introduced by the bz991469 fix. It breaks module add command included in a CLI module archive. For details see

https://issues.jboss.org/browse/WFLY-1913?focusedCommentId=12808246&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-12808246

Version-Release number of selected component (if applicable):
EAP 6.2.0.ER1

How reproducible:
Create a CLI module archive which includes 'module add' command involving a resource taken from the module archive. An example of such an archive can be found at WFLY-1913.
Comment 1 Ivo Studensky 2013-10-04 06:31:27 EDT
Relevant PR:

https://github.com/jbossas/jboss-eap/pull/509
Comment 3 JBoss JIRA Server 2013-10-07 04:16:53 EDT
Ivo Studensky <istudens@redhat.com> made a comment on jira WFLY-1913

Merged.
Comment 6 Petr Kremensky 2013-10-17 06:33:54 EDT
Created attachment 813260 [details]
Test CLI deployment archive
Comment 7 Petr Kremensky 2013-10-17 06:34:53 EDT
Hi Ivo,
How about the error message after undeploy operation?
ERROR [org.jboss.as.cli.CommandContext] Failed to execute archive script: JBAS014746: steps may not be null
Failed to execute archive script: JBAS014746: steps may not be null

All commands inside undeploy.scr are successfully executed, but after that this message will appear (same on win and linux, same message with 6.1.1). Is this a known issue or something wrong with CLI archive?

Just use attachment 813260 [details]
[standalone@localhost:9999 /] deploy --path=~/Downloads/install-mojarra-2.0.0.cli
[standalone@localhost:9999 /] undeploy --path=~/Downloads/install-mojarra-2.0.0.cli
Failed to execute archive script: JBAS014746: steps may not be null

Thanks.

Verified on EAP 6.2.0.ER6. 'module add' command inside CLI deployment archive now works on Windows as expected.
Comment 9 Ivo Studensky 2014-06-17 04:52:49 EDT
Petr, your deploy.scr/undeploy.src files are missing any 'deploy' step which is the cause of the warning you see.

Note You need to log in before you can comment on or make changes to this bug.