Bug 1014952 - [admin portal] cannot add Windows VM with 512MB memory, or more than 64GB
[admin portal] cannot add Windows VM with 512MB memory, or more than 64GB
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Roy Golan
Ilanit Stein
virt
: Regression
Depends On:
Blocks: 3.3snap1 3.3snap3
  Show dependency treegraph
 
Reported: 2013-10-03 03:57 EDT by Jiri Belka
Modified: 2015-03-31 09:07 EDT (History)
10 users (show)

See Also:
Fixed In Version: is24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20178 None None None Never
oVirt gerrit 20327 None None None Never
oVirt gerrit 21281 None None None Never

  None (edit)
Description Jiri Belka 2013-10-03 03:57:33 EDT
Description of problem:

In 3.2 I can create Windows 7 64bit with 512Mb of RAM. But in 3.3 you force me to use 1024!

-%-
Error while executing action:

test-tz:

    Cannot edit VM. Illegal memory size is provided, size needs to be between 1024 MB and 64000 MB.
-%-

Regression for Windows VM in comparison with 3.2.

<fyi>
Anyway, the admin is boss here and he should have possibility to define what he wants in supported range of qemu. This is not any freedom to force the user to use minimal 1024 Mb for Windows (or another value for different OS)...

Ridiculous, it allows me to set 256 Mb for RHEL6 64bit, but the installer fails because of not much memory. So I the ideas was to meet vendors' RAM recommendations, then there's inconsistency :-)

If you have decided to have some minimal memory for an OS type, 'New VM' dialog should be populated with "your" recommendation of memory but the admin should still have an opportunity to go below (if it is supported by qemu).

Comparison with VMWare product: I could create W2k12 VM, it created for me a VM with 2048 Mb of RAM. But after that I could put 128 Mb! Commercial software!
</fyi>

Version-Release number of selected component (if applicable):
is17

How reproducible:
100%

Steps to Reproduce:
1. Create a W7 64bit VM in 3.2 with 512 Mb
2. Export the VM
3. Create a W7 64bit VM in 3.3 with 512 Mb
4. Import the VM into 3.3
5. Edit this new imported VM (or just click OK)

Actual results:
impossible

Expected results:
should be possible, otherwise I suppose customer after upgrade would not be able to even change anything in VM properties.

Additional info:
There's bug that import mangles OS type of the imported VM. Thus do something like this to change the Os type to Windows:

update vm_static set os = 12 where vm_name = 'test-tz';
Comment 2 Michal Skrivanek 2013-10-04 13:13:02 EDT
we should only warn, or maybe even just a tooltip, but not block on other memory sizes...

[fixing flags]
Comment 3 Pavel Novotny 2013-10-29 12:19:16 EDT
FailedQA in rhevm-3.3.0-0.28.beta1.el6ev.noarch (is20).

Verification steps were done according to reproducer in comment#0. 
Optional approach: In 3.3 try to create a Windows 7 x64 VM with RAM less than 1024 MB or greater than 64000 MB. 

Result is the same - error dialog: Cannot add VM. Illegal memory size is provided, size needs to be between 1024 MB and 64000 MB.
Comment 4 Shai Revivo 2013-11-03 04:10:30 EST
in build 21
Comment 5 Ilanit Stein 2013-11-05 05:19:33 EST
Verified on is21.

Try to create a Windows 7 x64 VM with RAM less than 1024 MB or greater than 64000 MB - and see it succeeds.
Comment 6 Ilanit Stein 2013-11-05 06:58:42 EST
correction to comment #5: I checked less than 512M, not 1024M
Comment 7 Roy Golan 2013-11-12 06:30:18 EST
Ilanit I'm re-opening this. I'm fixing this to write an Event log and not a the file log so the automation could be fixed to check the event log
Comment 8 Ilanit Stein 2013-11-12 10:24:20 EST
Please consider returning memory min\max validation. 
It is not always clear from logs, why it fails to run. 
For example, Boot from pxe of a VM with 1M memory: VM turn into pause mode, and there was no clear error on vdsm log, pointing that the root cause was the small size of VM memory.
It seem more reasonable to me, to stop user at the point of creating the VM, than later on let him handle the consequences of the wrong memory size. 
Also warning in the audit log, might be not noticed.

Ilanit.
Comment 9 Jiri Belka 2013-11-12 10:34:32 EST
I don't agree. It's PEBKAC problem. Software should not always try to detect if a user put stupid settings. But if a memory value is accepted by UI and not by qemu, then this is different case. UI should not allow to accept lower mem value than qemu could accept.
Comment 10 Ilanit Stein 2013-11-13 06:24:38 EST
We can also add comment near the VM memory size in UI like: 
"Recommended values 256mb - 64,000mb for Other OS"
Comment 11 Ilanit Stein 2013-11-21 08:48:08 EST
Verified on is24.1
Comment 12 Michal Skrivanek 2013-11-21 11:38:05 EST
(In reply to Ilanit Stein from comment #10)
> We can also add comment near the VM memory size in UI like: 
> "Recommended values 256mb - 64,000mb for Other OS"

yeah, that would be nice a nice improvement
Comment 13 Itamar Heim 2014-01-21 17:24:59 EST
Closing - RHEV 3.3 Released
Comment 14 Itamar Heim 2014-01-21 17:25:41 EST
Closing - RHEV 3.3 Released
Comment 15 Itamar Heim 2014-01-21 17:29:14 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.