Bug 1014976 - [abrt] backintime-kde-1.0.26-2.fc19: app.py:259:__init__:TypeError: KDirModel.removeColumns() is a private method
[abrt] backintime-kde-1.0.26-2.fc19: app.py:259:__init__:TypeError: KDirModel...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: backintime (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
abrt_hash:f93ebb284ec20186656ec2742f0...
:
Depends On: 1021733
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 05:03 EDT by lonelywoolf
Modified: 2013-12-13 22:45 EST (History)
8 users (show)

See Also:
Fixed In Version: backintime-1.0.28-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-05 05:38:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (964 bytes, text/plain)
2013-10-03 05:03 EDT, lonelywoolf
no flags Details
File: environ (1.66 KB, text/plain)
2013-10-03 05:03 EDT, lonelywoolf
no flags Details
ABRT crash report (2.34 KB, application/x-7z-compressed)
2013-11-26 05:44 EST, Germano Massullo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1232694 None None None Never

  None (edit)
Description lonelywoolf 2013-10-03 05:03:18 EDT
Description of problem:
Just run backintime

Version-Release number of selected component:
backintime-kde-1.0.26-2.fc19

Additional info:
reporter:       libreport-2.1.7
cmdline:        python /usr/share/backintime/kde4/app.py
executable:     /usr/share/backintime/kde4/app.py
kernel:         3.11.3
runlevel:       N 3
type:           Python
uid:            1000

Truncated backtrace:
app.py:259:__init__:TypeError: KDirModel.removeColumns() is a private method

Traceback (most recent call last):
  File "/usr/share/backintime/kde4/app.py", line 1201, in <module>
    main_window = MainWindow( cfg, app_instance, kapp, kaboutdata )
  File "/usr/share/backintime/kde4/app.py", line 259, in __init__
    self.list_files_view_model.removeColumns( 3, 2 )
TypeError: KDirModel.removeColumns() is a private method

Local variables in innermost frame:
app_instance: <guiapplicationinstance.GUIApplicationInstance instance at 0x2265200>
widget: <PyQt4.QtGui.QWidget object at 0x2272dd0>
kaboutdata: <PyKDE4.kdecore.KAboutData object at 0x2176560>
self: <__main__.MainWindow object at 0x21763b0>
help_menu: <PyQt4.QtGui.QMenu object at 0x2176d40>
right_layout: <PyQt4.QtGui.QVBoxLayout object at 0x22724d0>
action: <PyQt4.QtGui.QAction object at 0x2272a70>
kapp: <PyKDE4.kdeui.KApplication object at 0x2176320>
config: <config.Config instance at 0x2265128>
Comment 1 lonelywoolf 2013-10-03 05:03:23 EDT
Created attachment 806953 [details]
File: backtrace
Comment 2 lonelywoolf 2013-10-03 05:03:27 EDT
Created attachment 806954 [details]
File: environ
Comment 3 Fedora Update System 2013-10-20 21:16:22 EDT
backintime-1.0.28-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/backintime-1.0.28-1.fc20
Comment 4 Fedora Update System 2013-10-20 21:19:10 EDT
backintime-1.0.28-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/backintime-1.0.28-1.fc19
Comment 5 Tim Jones 2013-10-21 13:30:18 EDT
Just tried those RPMs:

backintime-kde-1.0.28-1.fc19.noarch
backintime-common-1.0.28-1.fc19.noarch

.. and got this:

Traceback (most recent call last):
  File "/usr/share/backintime/kde4/app.py", line 1201, in <module>
    main_window = MainWindow( cfg, app_instance, kapp, kaboutdata )
  File "/usr/share/backintime/kde4/app.py", line 346, in __init__
    mnt = mount.Mount(cfg = self.config, profile_id = profile_id, parent = self)
  File "/usr/share/backintime/common/mount.py", line 52, in __init__
    pw_cache = password.Password_Cache(self.config)
  File "/usr/share/backintime/common/password.py", line 252, in __init__
    self.keyring_supported = tools.keyring_supported()
  File "/usr/share/backintime/common/tools.py", line 511, in keyring_supported
    backends = (keyring.backend.SecretServiceKeyring,
AttributeError: 'module' object has no attribute 'SecretServiceKeyring'
Comment 6 Fedora Update System 2013-10-21 14:31:06 EDT
Package backintime-1.0.28-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing backintime-1.0.28-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19639/backintime-1.0.28-1.fc20
then log in and leave karma (feedback).
Comment 7 Christopher Meng 2013-10-21 19:00:11 EDT
(In reply to Tim Jones from comment #5)

Yes, module 'SecretServiceKeyring' is needed since this version. Yesterday when I updated it I'd realized this issue. 

I'll post a package review of that absent module and after getting that approved then mark this update as stable.
Comment 8 Germano Massullo 2013-11-10 08:52:41 EST
Voted negative Karma points on Koji website
Comment 9 Tim Jones 2013-11-13 13:47:48 EST
This bug was reported for f19 and has now been unusable in the f19 update repo for some time.
Should the update not be reverted, or am I alone in being affected by this still *on f19*?
Comment 10 Fedora Update System 2013-11-25 20:33:11 EST
backintime-1.0.28-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/backintime-1.0.28-2.fc19
Comment 11 Fedora Update System 2013-11-25 20:34:34 EST
backintime-1.0.28-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/backintime-1.0.28-2.fc20
Comment 12 Germano Massullo 2013-11-26 05:24:32 EST
(In reply to Fedora Update System from comment #10)
> backintime-1.0.28-2.fc19 has been submitted as an update for Fedora 19.
> https://admin.fedoraproject.org/updates/backintime-1.0.28-2.fc19

Voted with a negative feedback
Comment 13 Christopher Meng 2013-11-26 05:30:56 EST
(In reply to Germano Massullo from comment #12)
> (In reply to Fedora Update System from comment #10)
> > backintime-1.0.28-2.fc19 has been submitted as an update for Fedora 19.
> > https://admin.fedoraproject.org/updates/backintime-1.0.28-2.fc19
> 
> Voted with a negative feedback

Can you provide me some details this time? If you still have problem, please try manually install python-SecretStorage package and tell me if it still refuses to start.

http://koji.fedoraproject.org/koji/buildinfo?buildID=480791

If after the installation the problem can be solved, I will rebuild the package with this dep added.

Thanks.
Comment 14 Germano Massullo 2013-11-26 05:44:13 EST
Created attachment 829188 [details]
ABRT crash report

Crashreport generated while having installed python-SecretStorage
http://koji.fedoraproject.org/koji/buildinfo?buildID=480791

# rpm -qa python-Secret*
python-SecretStorage-1.1.0-1.fc19.noarch
python-SecretStorage-doc-1.1.0-1.fc19.noarch
Comment 15 Christopher Meng 2013-11-26 05:54:07 EST
(In reply to Germano Massullo from comment #14)
> Created attachment 829188 [details]
> ABRT crash report
> 
> Crashreport generated while having installed python-SecretStorage
> http://koji.fedoraproject.org/koji/buildinfo?buildID=480791
> 
> # rpm -qa python-Secret*
> python-SecretStorage-1.1.0-1.fc19.noarch
> python-SecretStorage-doc-1.1.0-1.fc19.noarch

OK.

I think it's a python-keyring package related problem.

Please tell me your python-keyring version.

Thanks.
Comment 16 Germano Massullo 2013-11-26 06:03:14 EST
(In reply to Christopher Meng from comment #15)
> I think it's a python-keyring package related problem.
> 
> Please tell me your python-keyring version.
> 
> Thanks.

python-keyring-0.7-3.fc19.noarch
Comment 17 Christopher Meng 2013-11-26 06:06:36 EST
Got it.

You need to update it ;)

We have a 3.1 in testing, please install it (although the latest version is 3.2, I think it should work.)
Comment 18 Germano Massullo 2013-11-26 06:59:28 EST
python-keyring-3.1-1.fc19.noarch
yes now backintime starts correctly
Comment 19 Fedora Update System 2013-12-05 05:38:22 EST
backintime-1.0.28-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-12-13 22:45:34 EST
backintime-1.0.28-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.