Bug 1014984 - node-installer: refresh proxy features when proxy settings.yml is updated
Summary: node-installer: refresh proxy features when proxy settings.yml is updated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.0.2
Hardware: Unspecified
OS: Unspecified
medium
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-03 09:20 UTC by Dominic Cleal
Modified: 2019-09-26 14:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:40:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Dominic Cleal 2013-10-03 09:20:25 UTC
Description of problem:
If node-installer is re-run with different proxy features enabled each time (like --tftp=false and then --tftp=true), the feature list in Foreman isn't kept in sync as it was fetched when the proxy was first registered.

Version-Release number of selected component (if applicable):
node-installer-0.0.11-1.el6sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. node-install --tftp false --puppet true
2. check smart proxies list in Foreman
3. node-install --tftp true --puppet true
4. check smart proxies list in Foreman

Actual results:
"Puppet", then only "Puppet"

Expected results:
"Puppet", then "Puppet and TFTP"

Additional info:

Workaround: edit the proxy in the Foreman UI and re-save it, the feature list will be retrieved again.  In Foreman 1.4, there's a refresh link + API call.

Comment 2 Bryan Kearney 2014-07-24 12:01:20 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/3185 has been closed
-------------
Dominic Cleal
Applied in changeset commit:puppet-foreman|03978d6a5eb55da4fe5eb316db1833fbba344d14.

Comment 4 Bryan Kearney 2014-08-05 13:37:15 UTC
Created redmine issue http://projects.theforeman.org/issues/6932 from this bug

Comment 5 Bryan Kearney 2015-01-09 14:38:40 UTC
Upstream bug assigned to bkearney@redhat.com

Comment 6 Bryan Kearney 2015-08-25 17:22:38 UTC
Upstream bug component is WebUI

Comment 7 Bryan Kearney 2015-08-25 17:35:48 UTC
Upstream bug component is Installer

Comment 8 Bryan Kearney 2015-08-25 17:55:55 UTC
Upstream bug component is Content Management

Comment 9 Bryan Kearney 2015-08-25 17:57:37 UTC
Upstream bug component is Installer

Comment 10 Bryan Kearney 2016-03-15 14:43:41 UTC
the entire installer has been rebased, and we think this is fixed. Moving to ON_QA for verification.

Comment 12 Kedar Bidarkar 2016-04-12 10:46:19 UTC
VERIFIED with sat62-snap7.1

this has been working as expected since a long time now.

Comment 14 errata-xmlrpc 2016-07-27 08:40:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.