This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1014993 - update yum check description in yum manpage
update yum check description in yum manpage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum (Show other bugs)
6.4
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: packaging-team-maint
Karel Srot
: ManPageChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 05:34 EDT by Karel Srot
Modified: 2014-10-14 00:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: yum-3.2.29-60.el6
Doc Type: Bug Fix
Doc Text:
NO DOCS NEEDED
Story Points: ---
Clone Of:
: 1015000 (view as bug list)
Environment:
Last Closed: 2014-10-14 00:36:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2013-10-03 05:34:56 EDT
Description of problem:

man page states:

       check  Checks the local rpmdb and produces information on any problems it finds. You can pass the check command the  arguments  "dependencies"  or
              "duplicates", to limit the checking that is performed (the default is "all" which does both).

Actually, there is at least also yum check provides and yum check obsoletes. 
These are not describe which is confusing for the user who is trying to identify why "yum check" last very long while "yum check duplicates" and "yum check dependencies" are quick.

Version-Release number of selected component (if applicable):
yum-3.2.29-40.el6.noarch
Comment 1 Karel Srot 2013-10-03 05:35:55 EDT
Probably it would be worth of mentioning that yum check provides (and thus yum check all) is a bit time consuming.
Comment 2 Zdeněk Pavlas 2013-10-03 08:44:04 EDT
Well, the code is not consistent in what to check by default.

"yum check" command:
 "all" is used by default.

_rpmdb_warn_checks(chkcmd=None) function:
 ['dependencies', 'duplicates'] is used by default.

Probably the easiest way to resolve this is to resolve default only once,
in _rpmdb_warn_checks().  I've made a patch.
Comment 3 Karel Srot 2013-10-04 02:20:05 EDT
Is it a patch for the yum code or the patch for the man page? In the first case, please also update the man page with currently undocumented commands "obsoletes, provides" - maybe stating that "provides" runs quite a long time.

IMHO the default should not be 'all' just because of the long duration of 'provides' check.
Comment 4 Jan Zeleny 2013-10-04 02:59:38 EDT
(In reply to Zdeněk Pavlas from comment #2)
> Well, the code is not consistent in what to check by default.
> 
> "yum check" command:
>  "all" is used by default.
> 
> _rpmdb_warn_checks(chkcmd=None) function:
>  ['dependencies', 'duplicates'] is used by default.
> 
> Probably the easiest way to resolve this is to resolve default only once,
> in _rpmdb_warn_checks().  I've made a patch.

Zdenku, if the patch is ACKed upstream, please don't forget to include the commit info here for future reference. Thanks
Comment 5 Zdeněk Pavlas 2013-10-04 03:20:59 EDT
(In reply to Karel Srot from comment #3)
> Is it a patch for the yum code or the patch for the man page? In the first
> case, please also update the man page with currently undocumented commands
> "obsoletes, provides" - maybe stating that "provides" runs quite a long time.
> 
> IMHO the default should not be 'all' just because of the long duration of
> 'provides' check.

James thinks it's better to run all 4 checks by default, so I've just updated docs.

http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=d45aee8f
Comment 6 Zdeněk Pavlas 2013-10-04 03:35:29 EDT
(In reply to Jan Zeleny from comment #4)
> (In reply to Zdeněk Pavlas from comment #2)
> > Well, the code is not consistent in what to check by default.
> > 
> > "yum check" command:
> >  "all" is used by default.
> > 
> > _rpmdb_warn_checks(chkcmd=None) function:
> >  ['dependencies', 'duplicates'] is used by default.
> > 
> > Probably the easiest way to resolve this is to resolve default only once,
> > in _rpmdb_warn_checks().  I've made a patch.
> 
> Zdenku, if the patch is ACKed upstream, please don't forget to include the
> commit info here for future reference. Thanks

What, FUS spam generated at release time is not enough?
Comment 7 Zdeněk Pavlas 2013-10-04 03:57:24 EDT
Sorry, haven't noticed it's a RHEL bug.. It makes sense then.
Comment 10 Karel Srot 2014-07-02 03:52:53 EDT
Switching back to ASSIGNED.

See the snippet below. The "check" description is correct but the 2nd paragraph starting with "The  info  command..." seems to belong rather to the "info" subcommand section.

It is not a regression and I could file a separate bug for this issue but maybe it would be easier to fix it at once since this bug is about the "yum check" description.

yum-3.2.29-59.el6:

from man yum:

       check  Checks the local rpmdb and produces information on any problems  it  finds.  You  can
              pass  the  check  command  the arguments "dependencies", "duplicates", "obsoletes" or
              "provides", to limit the checking that is performed (the default is "all" which  does
              all).

              The  info  command  can  also take ranges of transaction ids, of the form start..end,
              which will then display a merged history as if all the transactions in the range  had
              happened at once.
              Eg.  "history info 1..4" will merge the first four transactions and display them as a
              single transaction.
Comment 14 errata-xmlrpc 2014-10-14 00:36:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1410.html

Note You need to log in before you can comment on or make changes to this bug.