Bug 1015008 - rhevm-manage-domains -action=add fail completely with only IPv6 DNS servers in /etc/resolv.conf
rhevm-manage-domains -action=add fail completely with only IPv6 DNS servers i...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-config (Show other bugs)
3.2.0
x86_64 Linux
high Severity high
: ---
: 3.4.0
Assigned To: Ravi Nori
Petr Beňas
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 05:52 EDT by Petter Reinholdtsen
Modified: 2016-02-10 14:21 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RedHat Enterprise Linux 6 and RHEV 3.2.
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petter Reinholdtsen 2013-10-03 05:52:47 EDT
I was unable to find the RHEV module in bugzilla, so I try to report it here.  Please reassign if it is the wrong bug metadata.

Description of problem:

I discovered this problem when trying to use RHEV in an IPv6 only environment.  The RHEV master maskine was set up with IPv4 and IPv6 addresses, and its /etc/resolv.conf was pointing to the networks DNS servers, with only IPV6 addresses listed.

When calling

  rhevm-manage-domains -action=add -domain=internal.network.no -provider=activeDirectory -user=rhevad -interactive

The program would fail with the message "No KDC can be obtained for domain internal.network.no".  The cause was that the program have its own DNS resolver implementation reading /etc/resolv.conf, and this implementation do not understand IPv6 addresses in the nameserver lines in /etc/resolv.conf.

Please fix rhevm-manage-domains to handle IPv6 DNS servers (and the rest of RHEV too, of course), or at least give a more understanding error message
when the home made DNS resolver find nameserver lines it do not understand.

We managed to work around this problem by assigning IPv4 addresses to the DNS servers, and changing /etc/resolv.conf on the RHEVM machine to use these addresses.
Comment 1 Itamar Heim 2013-10-04 02:14:47 EDT
moving to rhev-m. i suggest also opening a support ticket with red hat
Comment 3 Ravi Nori 2014-01-14 12:24:01 EST
Enclosing the resolve.conf ipv6 address in square brackets seems to do the trick.

Instead of 

fd79:1065:ac3e:0:3e97:eff:fe14:c386

I tried the below and rhevm-manage-domains worked fine

[fd79:1065:ac3e:0:3e97:eff:fe14:c386]

The code that reads the resolv.conf file is in JDK and looks like there could be an issue there.
Comment 4 Eli Mesika 2014-03-03 09:27:34 EST
moved to on QA please test with instructions from comment 3
Comment 6 Itamar Heim 2014-06-12 10:09:44 EDT
Closing as part of 3.4.0

Note You need to log in before you can comment on or make changes to this bug.