Bug 1015020 - [RHSC] 'Add Network' dialog for a cluster contains fields not relevant to RHS
[RHSC] 'Add Network' dialog for a cluster contains fields not relevant to RHS
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity high
: ---
: RHGS 2.1.2
Assigned To: anmol babu
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 06:13 EDT by Shruti Sampat
Modified: 2015-05-13 12:31 EDT (History)
9 users (show)

See Also:
Fixed In Version: cb11
Doc Type: Bug Fix
Doc Text:
Previously, fields which are not relevant to Red Hat Storage Console were displayed in the Add Network window. Now, with this update, a check is added to verify the application mode and the fields which are not applicable to Red Hat Storage Console are not displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:47:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 22189 None None None Never

  None (edit)
Description Shruti Sampat 2013-10-03 06:13:03 EDT
Description of problem:
------------------------
The Add Network dialog for a cluster, contains some fields and references that are not relevant to RHS. For e.g. -

The dialog shows the following sentence on top -

The Network will be added to the Data Center Default as well.

The reference to Data Center needs to be removed as it is not present anywhere else in the UI.

There is a section called Network Parameters, which has check boxes for 'VM Network'.

A sub-tab called Profiles is seen in the dialog, which has to do with vNIC Profiles.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.1-0.0.1.master.el6ev 

How reproducible:
Always

Steps to Reproduce:
1. Select a cluster and click on the Logical Networks tab.
2. Click on Add Network


Actual results:
Some of the fields displayed do not make sense for RHSC.

Expected results:
Those fields and references not relevant to RHSC need to be removed.

Additional info:
Comment 2 anmol babu 2013-12-01 00:00:00 EST
Which other fields need to be hidden 
VLan Tagging?
etc..
Comment 4 Dusmant 2013-12-09 10:25:58 EST
As we analysed more and discuss with multiple folks, we realized that none of the menu options under "Logical Network" tab makes any sense for RHSC/RHSS ( albeit it's required for RHEV ).

We are deciding to remove  all the menu options ( "Add Network", "Manage Networks" and "Set as Display" ) under the "Logical Network" Tab. The only purpose of "Logical Network" Tab will be to show the "ovirtmgmt" row. It can't be edited or removed anyway.
Comment 5 Shruti Sampat 2013-12-12 07:42:03 EST
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.27.beta.el6_5. All menus that were visible under the Logical Networks tab for a cluster are now not seen.
Comment 6 Shalaka 2014-01-06 06:11:16 EST
Please review the edited DocText.
Comment 8 errata-xmlrpc 2014-02-25 02:47:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.