Bug 1015026 - Cannot change localfs storage connection
Cannot change localfs storage connection
Status: CLOSED DUPLICATE of bug 950055
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Daniel Erez
Aharon Canan
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 06:35 EDT by Katarzyna Jachim
Modified: 2016-02-10 15:35 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 11:39:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Katarzyna Jachim 2013-10-03 06:35:14 EDT
Description of problem:
If you want to change path of the localfs storage connection, it always fails with "Domain is either partially accessible or entirely inaccessible"

From vdsm.log:
Thread-514::INFO::2013-10-03 11:30:26,149::fileSD::520::Storage.StorageDomain::(getStats) sdUUID=d8506641-027c-4efb-93ec-1d90d70c11a3 [Errno 2] No such file or directory: '/rhev/data-center/mnt/_home_rest__test__domain__1__2013__10__03__11__16__36__418573/d8506641-027c-4efb-93ec-1d90d70c11a3'
Thread-514::ERROR::2013-10-03 11:30:26,149::task::850::TaskManager.Task::(_setError) Task=`a995f64e-d927-45e2-8c30-a7f8430ffbe9`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 857, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/logUtils.py", line 45, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/storage/hsm.py", line 2772, in getStorageDomainStats
    stats = dom.getStats()
  File "/usr/share/vdsm/storage/fileSD.py", line 523, in getStats
    raise se.StorageDomainAccessError(self.sdUUID)
StorageDomainAccessError: Domain is either partially accessible or entirely inaccessible: ('d8506641-027c-4efb-93ec-1d90d70c11a3',)

Version-Release number of selected component (if applicable): is17


How reproducible:


Steps to Reproduce:
1. create a localfs storage domain
2. create another directory on the host with appropriate permissions (36:36)
3. put the storage domain to maintenance
4. copy the storage domain directory content to the new directory (not needed, will fail even if the 
5. try to change the storage domain and set path to the new one

Actual results: action fails with "Domain is either partially accessible or entirely inaccessible"


Expected results: should pass


Additional info:
Comment 1 Katarzyna Jachim 2013-10-03 06:37:26 EDT
Fix for "steps to reproduce":
4. copy the storage domain directory content to the new directory (not needed, fail also when the directory is empty)
Comment 3 Daniel Erez 2013-10-07 11:39:25 EDT
The described issue is a duplicate of bug 950055. As a quick workaround, restart vdsm service before updating the connection.

*** This bug has been marked as a duplicate of bug 950055 ***

Note You need to log in before you can comment on or make changes to this bug.