Bug 1015033 - acpid doesn't have its own entry in the /etc/sysconfig directory
acpid doesn't have its own entry in the /etc/sysconfig directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: acpid (Show other bugs)
6.4
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Jaroslav Škarvada
Andrej Manduch
: Patch
Depends On:
Blocks: 1159825
  Show dependency treegraph
 
Reported: 2013-10-03 06:46 EDT by Jordi Sanfeliu
Modified: 2016-02-16 16:11 EST (History)
3 users (show)

See Also:
Fixed In Version: acpid-1.0.10-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 16:11:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (3.31 KB, patch)
2013-10-09 07:48 EDT, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Jordi Sanfeliu 2013-10-03 06:46:14 EDT
Description of problem:

It's expected for a system administrator to know if someone has pressed (in)voluntarily the power button, which in turn forced (in the majority of cases) an unexpected server shutdown.

The acpid daemon needs the command line argument '-l, --logevents' to log information about all events and actions (including those related to button/power) in the syslog.

Currently the only way to include such argument is editing its SysVinit script which makes the solution ineffective because the changes will disappear in the next acpid update, forcing the system administrator to memorize those changes before the update.

The most elegant way would be if the acpid had its own file in the /etc/sysconfig/ directory which would be read by the SysVinit script during the start.

Version-Release number of selected component (if applicable):


How reproducible:

Always.


Steps to Reproduce:

1. Create and edit the file /etc/sysconfig/acpid to include the line:
OPTIONS="-l"
2. Restart acpid with 'service acpid restart'.
3. Press the power button in the server.


Actual results:

The event is not logged in syslog.


Expected results:

The event is logged in syslog.


Additional info:
Comment 3 Jaroslav Škarvada 2013-10-09 07:48:48 EDT
Created attachment 809864 [details]
Proposed fix
Comment 4 Jordi Sanfeliu 2013-10-09 09:52:14 EDT
(In reply to Jaroslav Škarvada from comment #3)
> Created attachment 809864 [details]
> Proposed fix

Looks perfect!

Thanks for accepting the suggestion and for your quick fix.
Regards.
Comment 5 RHEL Product and Program Management 2013-10-13 19:04:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 14 Andrej Manduch 2016-01-29 06:33:26 EST
Looks good to me. Test result can be found here: https://beaker.engineering.redhat.com/jobs/1206704

I'm setting it to verified.
Comment 16 errata-xmlrpc 2016-02-16 16:11:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0240.html

Note You need to log in before you can comment on or make changes to this bug.