Bug 1015065 - Add ability to disable LVM activation on boot
Add ability to disable LVM activation on boot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
: FutureFeature
: 1015110 (view as bug list)
Depends On:
Blocks: 1015110
  Show dependency treegraph
 
Reported: 2013-10-03 07:51 EDT by Martin Poole
Modified: 2016-11-25 08:07 EST (History)
8 users (show)

See Also:
Fixed In Version: initscripts-9.03.40-1.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1015110 (view as bug list)
Environment:
Last Closed: 2013-11-21 17:13:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add nolvm boot option (707 bytes, patch)
2013-10-03 07:51 EDT, Martin Poole
no flags Details | Diff

  None (edit)
Description Martin Poole 2013-10-03 07:51:42 EDT
Created attachment 807044 [details]
patch to add nolvm boot option

Description of problem:

Customer is suffering from a problem with LVM activation that requires the ability to boot the system without the normal wholesale LVM activation.

The proposal is to add the ability to disable the rc.sysinit lvm activation via a root file or cmdline option.

In addition this would provide an extremely useful diagnostic/recovery option when dealing with other LVM/storage problems.


Version-Release number of selected component (if applicable):

initscripts-9.03.38-1.el6_4.2.x86_64

Additional info:
Comment 1 Lukáš Nykrýn 2013-10-03 07:56:47 EDT
Do you need this for rhel-6.5 or could it wait for 6.6?
Comment 4 Lukáš Nykrýn 2013-10-03 09:22:02 EDT
*** Bug 1015110 has been marked as a duplicate of this bug. ***
Comment 19 errata-xmlrpc 2013-11-21 17:13:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1679.html

Note You need to log in before you can comment on or make changes to this bug.