Bug 1015071 - fail to delete snapshot based on a preallocated LV [NEEDINFO]
fail to delete snapshot based on a preallocated LV
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Yeela Kaplan
Elad
storage
:
Depends On:
Blocks: 1005256
  Show dependency treegraph
 
Reported: 2013-10-03 08:09 EDT by Aharon Canan
Modified: 2016-02-10 14:08 EST (History)
12 users (show)

See Also:
Fixed In Version: is18
Doc Type: Bug Fix
Doc Text:
Attempting to delete a snapshot based on a preallocated disk failed. Instead of deleting the snapshot, the source volume was deleted, so the virtual machine could not run. Now, during the snapshot process it creates a new volume which shrinks after the snapshot is merged back to the virtual machine. As a result, deleting a snapshot based on a preallocated disk works properly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:17:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
cboyle: needinfo? (ykaplan)


Attachments (Terms of Use)
logs (1.75 MB, application/x-gzip)
2013-10-03 08:09 EDT, Aharon Canan
no flags Details
logs01 (1.90 MB, application/x-gzip)
2013-10-03 08:30 EDT, Aharon Canan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19883 None None None Never
oVirt gerrit 19983 None None None Never

  None (edit)
Description Aharon Canan 2013-10-03 08:09:25 EDT
Created attachment 807057 [details]
logs

Description of problem:
trying to run VM after deleting his LSM snapshot fails

Version-Release number of selected component (if applicable):
is17

How reproducible:
100%

Steps to Reproduce:
1. set VM with disk, 2 storage domains
2. LSM the disk
3. turn off VM
4. delete the automatic snapshot
5. try to run VM

Actual results:
it looks like we delete the source LV instead of the snapshot LV, VM doesn't run

Expected results:
VM should run properly 

Additional info:
===========
281364d7-7343-4cf9-b1c9-34a517a32330::ERROR::2013-10-03 14:45:56,240::task::850::TaskManager.Task::(_setError) Task=`281364d7-7343-4cf9-b1c9-34a517a32330`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 857, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/storage/task.py", line 318, in run
    return self.cmd(*self.argslist, **self.argsdict)
  File "/usr/share/vdsm/storage/securable.py", line 68, in wrapper
    return f(self, *args, **kwargs)
  File "/usr/share/vdsm/storage/sp.py", line 1946, in mergeSnapshots
    sdUUID, vmUUID, imgUUID, ancestor, successor, postZero)
  File "/usr/share/vdsm/storage/image.py", line 1136, in merge
    srcVol.shrinkToOptimalSize()
  File "/usr/share/vdsm/storage/blockVolume.py", line 317, in shrinkToOptimalSize
    volParams = self.getVolumeParams()
  File "/usr/share/vdsm/storage/volume.py", line 982, in getVolumeParams
    volParams['imgUUID'] = self.getImage()
  File "/usr/share/vdsm/storage/blockVolume.py", line 496, in getImage
    return self.getVolumeTag(TAG_PREFIX_IMAGE)
  File "/usr/share/vdsm/storage/blockVolume.py", line 466, in getVolumeTag
    return _getVolumeTag(self.sdUUID, self.volUUID, tagPrefix)
  File "/usr/share/vdsm/storage/blockVolume.py", line 664, in _getVolumeTag
    tags = lvm.getLV(sdUUID, volUUID).tags
  File "/usr/share/vdsm/storage/lvm.py", line 869, in getLV
    raise se.LogicalVolumeDoesNotExistError("%s/%s" % (vgName, lvName))
LogicalVolumeDoesNotExistError: Logical volume does not exist: ('99d8eee2-8aae-424f-8885-ab91c6a1ecbd/_remove_me_zFVftoks_c0ac6f42-b87b-4a81-acbd-9f0b04363041',)
Comment 2 Aharon Canan 2013-10-03 08:24:51 EDT
looks like deleting snapshot fails even without LSM, just regular one.
Comment 4 Aharon Canan 2013-10-03 08:30:15 EDT
Created attachment 807072 [details]
logs01
Comment 5 Elad 2013-10-16 06:34:12 EDT
Delete to snapshot that was created to a preallocated disk is working properly.

Verified with RHEVM3.3 - is18.1
Comment 6 Charlie 2013-11-27 19:34:36 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 8 errata-xmlrpc 2014-01-21 11:17:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.