Bug 1015072 - Blivet should not mount stuff on its own
Blivet should not mount stuff on its own
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: David Lehman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 08:09 EDT by Jan Safranek
Modified: 2015-03-05 09:05 EST (History)
3 users (show)

See Also:
Fixed In Version: python-blivet-0.61.0.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-05 09:05:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Safranek 2013-10-03 08:09:34 EDT
blviet.reset() mounts btrfs filesystems to get list of subvolumes and other info.

In application mode, it must not mount anything anywhere, only when application explicitly asks so. As result, blivet won't list subvolumes of unmounted btrfs volumes, but that's fine.
Comment 2 Jan Safranek 2013-10-03 08:12:23 EDT
As side note, mounting to /tmp is highly unsafe, /var/run/blivet with appropriate SELinux label would be much better if the mounting is absolutely necessary from some technical reason.
Comment 6 Jan Safranek 2015-01-13 10:01:32 EST
Tested with mkfs.btrfs && strace -f -o trace reproducer.py.

- reproducer.py can be anything that initializes blivet, e.g. the one from bug #1077250
- on RHEL 7.0 (python-blivet-0.18.34-1.el7.noarch), there is in the strace output:
30464 execve("/bin/mount", ["mount", "-t", "btrfs", "-o", "subvolid=5", "/dev/vdb5", "/tmp/btrfs-tmp.12YCS23j"], [/* 29 vars */] <unfinished ...>

- in RHEL 7.1 (python-blivet-0.61.0.20-1.el7.noarch) there is no such exec() in strace -> it looks fixed.
Comment 9 errata-xmlrpc 2015-03-05 09:05:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0313.html

Note You need to log in before you can comment on or make changes to this bug.