Bug 1015099 - Dist-geo-rep : geo-rep status detail gives wrong info of files synced when a single file is modified multiple times.
Dist-geo-rep : geo-rep status detail gives wrong info of files synced when a ...
Status: CLOSED NEXTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
amainkar
status
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 08:57 EDT by Vijaykumar Koppad
Modified: 2015-08-06 10:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-06 10:50:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-10-03 08:57:16 EDT
Description of problem: geo-rep status detail gives wrong info of files synced when a single file is modified multiple times.

[root@ninja ~]# gluster volume geo-replication snapstore gladiator.lab.eng.blr.redhat.com::snapstore status detail
 
                              MASTER: snapstore  SLAVE: gladiator.lab.eng.blr.redhat.com::snapstore
 
NODE                                HEALTH    UPTIME            FILES SYNCD    FILES PENDING    BYTES PENDING    DELETES PENDING  
---------------------------------------------------------------------------------------------------------------------------------
ninja.lab.eng.blr.redhat.com        Stable    1 day 17:02:33    42             1                2.6GB            0                
vertigo.lab.eng.blr.redhat.com      Stable    1 day 17:02:18    0              0                0Bytes           0   


The above  master volume has only 4 files, which are being modified, but status detail shows files synced as 42, when effectively it has synced only 4 files.
I guess it is considering data changes in changelog for a file as seperate files synced, when it has to consider only entry changes in the changelog. 

Version-Release number of selected component (if applicable):glusterfs-3.4.0.33rhs-1.el6rhs.x86_64


How reproducible:Happens every time 


Steps to Reproduce:
1.create geo-rep relationship between master and slave. 
2.create one file on master.
3.modify it manytimes , so that each update will have entry in different changelog. 
4. Check the status detail for files synced

Actual results:It gives wrong info of files synced in status detail 


Expected results: It should give correct info in geo-rep status detail.  


Additional info:
Comment 7 Aravinda VK 2015-08-06 10:50:40 EDT
files synced column is removed from status output in RHGS 3.1. If we introduce percistent store while working on RFE 988857, we can show number of Files synced. But with the existing limitation, this column is removed since it will mislead the user. 

Current status shows ENTRY, DATA and METADATA as three separate columns. Thease values will get reset whenever Geo-rep worker restarted. 

Closing this bug for the same reason. Please reopen this bug if the issue is found again.

Note You need to log in before you can comment on or make changes to this bug.