Bug 1015119 - aqute-bnd: FTBFS in rawhide
aqute-bnd: FTBFS in rawhide
Status: CLOSED DUPLICATE of bug 991985
Product: Fedora
Classification: Fedora
Component: aqute-bnd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 09:26 EDT by Mikolaj Izdebski
Modified: 2016-01-31 20:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-08 08:51:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
aqute-bnd-ftbfs.patch (721 bytes, patch)
2013-12-18 20:29 EST, Paulo Andrade
no flags Details | Diff

  None (edit)
Description Mikolaj Izdebski 2013-10-03 09:26:19 EDT
Description of problem:
Package aqute-bnd fails to build from source in rawhide.

Version-Release number of selected component (if applicable):
0.0.363-8

Probable cause of build failure:

src/main/java/aQute/bnd/ant/WrapTask.java:45: error: no suitable method found for doWrap(File,File,File,<null>,int,Hashtable<String,Object>)
					      	     		 bnd.doWrap(bndFile.exists()?bndFile:null, file, output, null, 0, getProject().getProperties());
								 					   	 	    ^
    method bnd.doWrap(File,File,File,File[],int,Map<String,String>) is not applicable
      (actual argument Hashtable<String,Object> cannot be converted to Map<String,String> by method invocation conversion)
    method bnd.doWrap(String[],int) is not applicable
      (actual and formal argument lists differ in length)

Full build logs from Koji:

Package aqute-bnd (6019793):
  noarch (6019862):
    root.log            : http://kojipkgs.fedoraproject.org/work/tasks/9862/6019862/root.log
    build.log           : http://kojipkgs.fedoraproject.org/work/tasks/9862/6019862/build.log
    state.log           : http://kojipkgs.fedoraproject.org/work/tasks/9862/6019862/state.log
    mock_output.log     : http://kojipkgs.fedoraproject.org/work/tasks/9862/6019862/mock_output.log

Additional info:
[1] http://fedoraproject.org/wiki/Packaging:Java
[2] http://fedoraproject.org/wiki/Packaging:Guidelines
Comment 1 Paulo Andrade 2013-12-18 20:29:40 EST
Created attachment 838712 [details]
aqute-bnd-ftbfs.patch

This patch appears to correct the problem for me.
Comment 2 Mikolaj Izdebski 2014-01-08 08:51:14 EST
I'll look into it soon.

*** This bug has been marked as a duplicate of bug 991985 ***

Note You need to log in before you can comment on or make changes to this bug.