Bug 101512 - package manager displays incorrect information
package manager displays incorrect information
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-packages (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-01 22:49 EDT by Elton Woo
Modified: 2007-04-18 12:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:29:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elton Woo 2003-08-01 22:49:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
In installed Workstation, ans *DID NOT* select to install KDE desktop.
Nevertheless, the KDE desktop was installed. *However* whenever I run
the package manager to install additional packages, for the KDE
section, it *consistently* reports "0 of 16 packages installed"!!! ...
even after I had just recently installed the kdepim  (as kmail was
complaining that the addressbook module was absent).

Version-Release number of selected component (if applicable):
redhat-config-packages-1.9.1-1

How reproducible:
Always

Steps to Reproduce:
1. Install using Workstation with default packages
2. After installation, select KDE session from the GDM.
3. Run software manager to install any KDE application
    

Actual Results:  Both Gnome and KDE desktops were installed.
Running software manager (effectively) claims that no KDE applications
are installed.

Expected Results:  Only Gnome desktop should be installed.
If, for example, two KDE applications are installed package manager should
report 2 of 16 packages are installed,

Additional info:
Comment 1 Charles R. Anderson 2003-08-02 23:07:31 EDT
I did an upgrade from Shrike to Severn, and r-c-p says that no X Window System,
GNOME, or KDE packages are installed (0 of 35, 0 of 35, and 0 of 16,
respectively).  Of course, they are installed.  This appears to be a problem
only with Group View.
Comment 2 Jeremy Katz 2003-08-06 17:43:12 EDT
This is due to the definition we use for "installed" which is all mandatory
packages installed, which isn't necessarily the case after an upgrade :/

Note You need to log in before you can comment on or make changes to this bug.