Bug 1015125 - Low contrast of the new theme
Low contrast of the new theme
Status: CLOSED WONTFIX
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.15
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
: 1063385 (view as bug list)
Depends On: 1012224
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 09:29 EDT by Jiri Benc
Modified: 2018-02-05 19:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-11 00:32:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Benc 2013-10-03 09:29:48 EDT
The new theme is very low contrast. In particular:

1. machine details (things like Location, Type, Lab Controller) is light grey text on light grey background, this is near to unreadable,
2. messages that should be highlighted (like information about started provisioning) is middle-dark yellow on yellow background, this is very easy to miss on the page and very badly readable,
3. top menu is middle-dark grey on light grey background.

In general, it's very hard to orientate quickly on the page as you have to focus for a while at a given spot to be able to read the contents.
Comment 2 Nick Coghlan 2014-02-10 18:25:40 EST
*** Bug 1063385 has been marked as a duplicate of this bug. ***
Comment 3 Nick Coghlan 2014-02-10 18:29:50 EST
We will be adhering relatively closely to the default Bootstrap colour scheme for the upstream project, but theming support for particular installations is intended as a future feature.
Comment 4 Roman Joost 2016-07-11 00:32:05 EDT
Dear Jiri,

I acknowledge the fact that the contrast with the new theme is low. However, that's a problem with bootstrap and will hopefully be solved in upcoming bootstrap versions. It is unfortunately a problem with all our applications, which use bootstrapt. We certainly don't want to play in the UX field and address all bootstrap's short comings. Furthermore, we do not intend to add any theming capabilities for users to Beaker. For that, stylish is probably the best option.

Having said that, I've checked with a colleague who is color blind. He's using methods to force his own color scheme onto the application and that seems to be working reasonably well.

Note You need to log in before you can comment on or make changes to this bug.