Bug 101515 - battstat-applet-2 does not retain configuration values after it has been removed from the panel
battstat-applet-2 does not retain configuration values after it has been remo...
Status: CLOSED UPSTREAM
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-applets (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-02 01:19 EDT by John Beimler
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 08:52:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Beimler 2003-08-02 01:19:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030730
Mozilla Firebird/0.6.1

Description of problem:
After removing the battery status applet, if it is re-added to the panel, it
reverts to its default state instead of the configuration it had been changed to
in the previous run.

Version-Release number of selected component (if applicable):
gnome-applets-2.2.0-8

How reproducible:
Always

Steps to Reproduce:
1. Configure the status applet differently than defaults
2. Remove the applet from the panel
3. Add the applet back to the panel
    

Actual Results:  Applet reverts to original / default settings

Expected Results:  Applet would retain state between runs.

Additional info:
Comment 1 Havoc Pennington 2003-08-05 18:23:14 EDT
This is the same for all applets, the properties of the applet 
are per-instance not global.

There's a bug on bugzilla.gnome.org about improving this,
with some discussion.
Comment 2 John Beimler 2003-08-05 20:57:56 EDT
I must not be being clear. I log in as myself. I put the batstat applet on the
panel. I don't want the color changing battery there, so I remove it, and
replace it with the percentages.

Since polling ACPI chews processor, I don't run the applet all the time, so I
close it down. 

When I load it again, the color changing battery is back, and my percentages are
gone.

I also lose my preferences if I log out and log back in.

If this is standard, its really stupid. I can't believe an application would not
retain states between runs.
Comment 3 Havoc Pennington 2003-08-05 22:12:18 EDT
The point is that applet settings are per-instance. That is, you can add 
the same applet to the panel multiple times. For example you can add 
the system monitor several times and set each one up different in preferences;
one monitor might show CPU and another memory for example.

The settings should be retained across login/logout, but they are only retained 
as long as the applet is actually on the panel. If you remove the applet from 
the panel, that instance of the applet is deleted.

The discussion on bugzilla.gnome.org suggests something like "new applets 
get the settings from the most recent instance of the same applet", so 
for example if I have a system monitor that displays memory usage, and 
create a new system monitor applet, then the new one will also display 
memory usage by default. But then if I changed the new one it would 
only change the new one, not both of them.

I don't remember the whole gnome.org discussion, though.
Comment 4 John Beimler 2003-08-05 22:45:44 EDT
hp: Thanks for the clear explination. I appreciate it.
Comment 5 Mark McLoughlin 2004-07-19 08:52:47 EDT
Here's the upstream bug:

  http://bugzilla.gnome.org/show_bug.cgi?id=32225

Closing as UPSTREAM

Note You need to log in before you can comment on or make changes to this bug.