Bug 1015177 - Handle vmcores uploaded with spaces in the name
Handle vmcores uploaded with spaces in the name
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: retrace-server (Show other bugs)
el6
All Linux
low Severity low
: ---
: ---
Assigned To: Michal Toman
Fedora Extras Quality Assurance
: TestCaseProvided
: 1025123 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 10:59 EDT by Dave Wysochanski
Modified: 2015-03-22 20:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: retrace-server-1.12-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-15 14:58:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Wysochanski 2013-10-03 10:59:10 EDT
Description of problem:
Today we can't queue vmcores if a space is in the name.  This is a special case and probably low priority but it would be good if it can be handled, or there is some workaround.

Version-Release number of selected component (if applicable):
retrace-server-1.10-1.el6.noarch

How reproducible:
Probably every time but unsure.

Steps to Reproduce:
1. Upload a vmcore to ftp site with a space in the name.  Example: "
2.
3.

Actual results:
Trying to queue it from 'manager' gives "There is no such task"

Expected results:
Able to queue the vmcore from the 'manager' page same as other vmcores.

Additional info:
I tried to use "%20" added to the URL but got the same result.

I can provide a example in our local system.
Comment 3 Michal Toman 2013-10-31 03:27:34 EDT
*** Bug 1025123 has been marked as a duplicate of this bug. ***
Comment 4 Michal Toman 2014-02-26 10:15:00 EST
Fixed in upstream

commit bb57b79f96dc706fcce08510bc080451ab9f027d
Author: Michal Toman <mtoman@redhat.com>
Date:   Wed Feb 26 16:12:32 2014 +0100

    use urllib.quote() instead of urllib.quote_plus()
    
    the '+' gets double quoted when used within <a> tag, while '%20' does not
    
    Signed-off-by: Michal Toman <mtoman@redhat.com>
Comment 5 Fedora Update System 2014-02-27 08:46:39 EST
retrace-server-1.11-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/retrace-server-1.11-1.el6
Comment 6 Fedora Update System 2014-03-01 02:11:39 EST
Package retrace-server-1.11-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing retrace-server-1.11-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0687/retrace-server-1.11-1.el6
then log in and leave karma (feedback).
Comment 8 Dave Wysochanski 2014-03-07 16:07:43 EST
Looks fixed to me.  I did not upload a vmcore though to the ftp site and try that method.  Submitting a vmcore 'vmcore with spaces' via 'custom core location' worked though.  I did not need to quote the file - just provide the full path with spaces included.
Comment 9 Fedora Update System 2014-07-31 07:52:46 EDT
retrace-server-1.12-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/retrace-server-1.12-2.el6
Comment 11 Fedora Update System 2014-08-15 14:58:04 EDT
retrace-server-1.12-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.