Bug 101522 - Http installs from public_html directories fail
Summary: Http installs from public_html directories fail
Status: CLOSED DUPLICATE of bug 101265
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-02 14:47 UTC by Need Real Name
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:57:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-08-02 14:47:50 UTC
Description of problem:
Attempts to perform http installs from user websites fail due to extra / in URL.
 For example, attempting to install from http://192.168.1.1/~gboyce/redhat/ fail
on an attempt to retrieve http://192.168.1.1//~gboyce/redhat/stage.img.  The
extra slash seems to appear on all http installs, but apache deals with the
extra slash when the install isn't from a user directory

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1.Copy install sources to public_html
2.Kick off http install with http://server/~username/directory
3.Watch it fail to install
    
Actual results:
installer grabs http://192.168.1.1//~gboyce/redhat/stage.img

Expected results:
installer grabs http://192.168.1.1/~gboyce/redhat/stage.img

Additional info:

Comment 1 Bill Nottingham 2003-08-05 03:32:45 UTC

*** This bug has been marked as a duplicate of 101265 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:57:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.