Bug 1015220 - can't log in as ordinary user after text install unless under user spoke, password field is last one filled out
can't log in as ordinary user after text install unless under user spoke, pas...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-10-03 12:53 EDT by Andre Robatino
Modified: 2013-10-16 06:29 EDT (History)
11 users (show)

See Also:
Fixed In Version: anaconda-20.22-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 06:29:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.ifcfg.log (1.44 KB, text/plain)
2013-10-03 15:59 EDT, Andre Robatino
no flags Details
anaconda.log (13.46 KB, text/plain)
2013-10-03 16:01 EDT, Andre Robatino
no flags Details
anaconda.packaging.log (384.60 KB, text/plain)
2013-10-03 16:02 EDT, Andre Robatino
no flags Details
anaconda.program.log (22.43 KB, text/plain)
2013-10-03 16:03 EDT, Andre Robatino
no flags Details
anaconda.storage.log (76.67 KB, text/plain)
2013-10-03 16:04 EDT, Andre Robatino
no flags Details
syslog (70.91 KB, text/plain)
2013-10-03 16:05 EDT, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2013-10-03 12:53:20 EDT
Description of problem:
I created both root and ordinary user accounts during text installs from the 20 Beta TC1 DVD (both i386 and x86_64). After install, I can't log in as ordinary user using the password specified during install. The root account works fine. I can use the passwd command as root to set the ordinary user password to the same one as specified during install, and am then able to log in as ordinary user.

Version-Release number of selected component (if applicable):
anaconda-20.21-1

How reproducible:
always

Steps to Reproduce:
1. text install, create root and ordinary user accounts
2. after install, try to log in as ordinary user

Actual results:
can't log in as ordinary user using originally specified password. can reset password with passwd command, then account works
Comment 1 Andre Robatino 2013-10-03 13:06:16 EDT
Proposing as Beta Blocker according to  https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Expected_installed_system_boot_behavior : "A system installed without a graphical package set must boot to a state where it is possible to log in through at least one of the default virtual consoles." (NOTE: I did minimal installs, not GNOME or KDE. There is a similar criterion for release-blocking desktops. It's unlikely the behavior depends on the installed package set.)
Comment 2 David Shea 2013-10-03 14:18:35 EDT
I'm not able to reproduce this. Please attach the log files from /var/log/anaconda. What keyboard layout did you use during the install?
Comment 3 Andre Robatino 2013-10-03 15:58:04 EDT
Should be easy to reproduce - I used the default keyboard and language. I used weak passwords which gave me the standard warning prompts during install. This was from the DVD, not the netinst, so should be 100% reproducible. Will attach all files in /var/log/anaconda except for ks-script-ZDYBvu.log which is 0 bytes.
Comment 4 Andre Robatino 2013-10-03 15:59:16 EDT
Created attachment 807241 [details]
anaconda.ifcfg.log
Comment 5 Andre Robatino 2013-10-03 16:01:30 EDT
Created attachment 807242 [details]
anaconda.log
Comment 6 Andre Robatino 2013-10-03 16:02:24 EDT
Created attachment 807244 [details]
anaconda.packaging.log
Comment 7 Andre Robatino 2013-10-03 16:03:27 EDT
Created attachment 807246 [details]
anaconda.program.log
Comment 8 Andre Robatino 2013-10-03 16:04:26 EDT
Created attachment 807249 [details]
anaconda.storage.log
Comment 9 Andre Robatino 2013-10-03 16:05:12 EDT
Created attachment 807251 [details]
syslog
Comment 10 Andre Robatino 2013-10-03 19:07:10 EDT
After a lot of trial and error (including reproducing in KVM, using either strong or weak passwords), I found that it only fails if the user is in the wheel group (which is how I normally create it). Can you try it with the user as administrator?
Comment 11 Andre Robatino 2013-10-03 19:39:12 EDT
I also found that the bug happens whether or not there is a root account. Hence, if one creates just an administrator user account, it's impossible to log in via password at all - you'd need to use the passwd command in single-user mode to set the password properly and allow normal login.
Comment 12 David Shea 2013-10-04 10:44:23 EDT
We're re-encrypting the password every time something in the user spoke is changed. Patch sent.
Comment 13 Andre Robatino 2013-10-04 16:38:10 EDT
Confirmed that user administrator password works if password field is filled out last (previously I did them from top to bottom, and administrator is the only one that comes after password).
Comment 14 Fedora Update System 2013-10-04 18:23:11 EDT
anaconda-20.22-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.22-1.fc20
Comment 15 Fedora Update System 2013-10-06 01:31:58 EDT
Package anaconda-20.22-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.22-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18430/anaconda-20.22-1.fc20
then log in and leave karma (feedback).
Comment 16 Andre Robatino 2013-10-08 15:06:04 EDT
Verified fixed in 20 Beta TC2 (anaconda 20.22-1) when I fill out the user section as usual (administrator checkbox after user password).
Comment 17 Fedora Update System 2013-10-08 19:38:17 EDT
anaconda-20.23-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.23-1.fc20
Comment 18 Mike Ruckman 2013-10-09 17:00:20 EDT
Discussed this in 2013-10-09 Blocker Review Meeting [1]. Voted an AcceptedBlocker as it violates the following F20 alpha release criterion for text installs where the user password isn't the last spoke entered: "A system installed without a graphical package set must boot to a state where it is possible to log in through at least one of the default virtual consoles." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-09/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Expected_installed_system_boot_behavior
Comment 19 Adam Williamson 2013-10-16 06:29:30 EDT
20.25 went stable, so closing.

Note You need to log in before you can comment on or make changes to this bug.