Bug 1015243 - Test latest domain configuration against previous versions of EAP
Test latest domain configuration against previous versions of EAP
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER6
: EAP 6.2.0
Assigned To: Kabir Khan
Petr Kremensky
Russell Dickenson
:
Depends On: 1015245 1098065
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 13:45 EDT by Kabir Khan
Modified: 2015-11-24 06:06 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 06:06:38 EST
Type: Task
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2172 Blocker Resolved Resurrect the mixed domain testing and fix any problems 2016-01-25 03:10 EST

  None (edit)
Description Kabir Khan 2013-10-03 13:45:18 EDT

    
Comment 1 Kabir Khan 2013-10-04 05:17:28 EDT
This is necessary to be able to test interoperatbility of a EAP 6.2 DC running EAP 6.0.x and 6.1.x slaves.
Comment 2 Rostislav Svoboda 2013-10-07 02:44:59 EDT
This is big effort, already in late tests execution phase (waiting for ER5), targeting for test development phase for EAP 6.3.
Comment 4 Kabir Khan 2013-10-08 05:23:44 EDT
The work has already been done. It lives here: https://github.com/jbossas/jboss-eap/pull/510.
Comment 5 Rostislav Svoboda 2013-10-08 05:58:28 EDT
Brian, Kabir, thank you for comments. Changing qa_ack to +. There is no description and BZ title implied that it would be QA task.
Comment 6 Brian Stansberry 2013-12-16 20:19:39 EST
This was actually done for 6.2 and could be closed, but since it's an internal testing task and we need to do the same for 6.3, let's just keep the same issue. :-)
Comment 7 Kabir Khan 2014-04-13 06:49:40 EDT
6.3 PR https://github.com/jbossas/jboss-eap/pull/1233
Comment 9 Kabir Khan 2014-04-16 04:47:34 EDT
Carlo, you need to put the the EAP 6.2.0 dist into the location pointed to by -Djboss.test.mixed.domain.dir.

Note that it still 'reworks' the jars, so that the top-level directory is 'jboss-eap-6.2.0', the zip name is also important, e.g:

[~]
$unzip -l old-as7-releases/jboss-eap-6.2.0.zip
Archive:  old-as7-releases/jboss-eap-6.2.0.zip
  Length     Date   Time    Name
 --------    ----   ----    ----
        0  11-20-13 21:47   jboss-eap-6.2.0/
        0  11-20-13 21:47   jboss-eap-6.2.0/.installation/
        0  11-20-13 21:47   jboss-eap-6.2.0/appclient/
        0  04-06-14 11:34   jboss-eap-6.2.0/appclient/configuration/
     7607  11-20-13 21:47   jboss-eap-6.2.0/appclient/configuration/appclient.xml
--- SNIP ---
Comment 10 Kabir Khan 2014-05-22 04:53:21 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=1098065 makes this a bit more user friendly
Comment 11 Petr Kremensky 2014-08-26 03:16:19 EDT
Can we close this one?
Comment 12 Brian Stansberry 2014-08-26 10:41:49 EDT
Comment 6 still applies, just with different versions.

I'm indifferent between closing this and opening another vs just continuing on; whatever anyone prefers.
Comment 15 Kabir Khan 2015-11-24 05:45:34 EST
Traditionally we only add these in the next minor or major, so 7.0.0 has the test for 6.4.0, and 6.4.0 introduced the test for 6.3.0 and so on. As I understand it this is for 6.4.x testing against 6.4.0, but we should not be changing the management API in micros which makes this test pointless. However that is the basic rule, so if we have actually changed something for whatever reason we can add this test.

As an aside, the setup of this test is quite complex, with duplicated profiles in the domain.xml. Upstream (i.e. WF10/EAP 7) we have simplified it a lot with a 'DomainAdjuster' per version (e.g. https://github.com/wildfly/wildfly/blob/master/testsuite/mixed-domain/src/test/java/org/jboss/as/test/integration/domain/mixed/eap630/DomainAdjuster630.java). This now boots up the DC in admin only mode, adjusts the profile to something which can work, and then starts the DC normally and the legacy HC.
Comment 16 Jan Martiska 2015-11-24 06:06:38 EST
Okay then, Kabir is actually right that we probably don't need this for EAP 6.4.0. And because there will be no more minor releases of 6.x, I think this can be closed.

Note You need to log in before you can comment on or make changes to this bug.