Bug 1015280 - 'Name' field in the 'New Data Center' dialog loses focus while typing in it in some scenarios
'Name' field in the 'New Data Center' dialog loses focus while typing in it i...
Status: CLOSED WORKSFORME
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.5.0
Assigned To: Greg Sheremeta
bugs@ovirt.org
ux
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 15:14 EDT by Einav Cohen
Modified: 2016-02-10 14:45 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-30 18:04:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-cast: 'Name' field loses focus (1.48 MB, video/ogg)
2013-10-03 15:15 EDT, Einav Cohen
no flags Details

  None (edit)
Description Einav Cohen 2013-10-03 15:14:28 EDT
Description of problem:
'Name' field in the 'New Data Center' dialog loses focus while typing in it in some scenarios, e.g. while removal of another data-center is being performed in the background.

Version-Release number of selected component (if applicable):
latest upstraem ["master"]

How reproducible:
100% (at least in the detailed scenarios)

Steps to Reproduce:
1. Go to the Data Centers main tab
2. Select a Data Center to be removed
3. click "Remove" and confirm by clicking "OK" in the confirmation dialog
4. [quickly, before the Data Center disappears from the grid] click "New" to open the 'New Data Center" dialog
5. in the dialog: start typing text in the 'Name' field. keep typing, and while typing - observe the removed Data Center disappearing from grid in the background

Actual results:
'Name' field loses it focus once the removed Data Center disappears from the grid in the background; so even though I keep typing text, it is not being filled in the text-box

Expected results:
'Name' field should keep its focus (i.e. text that I am typing should go into the text box)

Additional info:
- see attached video that demonstrates the scenario.
- I think that this used to happen a lot more before the upgrade to gwt 2.5, but I could be wrong.
- same scenario for the Clusters main tab didn't reproduce for me (i.e. Clusters  grid / 'New Cluster' dialog behavior is OK), not sure what is the root cause of the difference (text-box type? sub-tabs?).
Comment 1 Einav Cohen 2013-10-03 15:15:40 EDT
Created attachment 807230 [details]
screen-cast: 'Name' field loses focus
Comment 2 Itamar Heim 2014-01-12 03:42:28 EST
setting target release to current version for consideration and review. please do not push non-RFE bugs to an undefined target release to make sure bugs are reviewed for relevancy, fix, closure, etc.
Comment 3 Einav Cohen 2014-01-15 11:08:31 EST
may be more difficult to reproduce now that changes should be reflected immediately - maybe more easily reproducible by working with two GUI sessions at the same time [select a DC in one GUI, remove it in the other, quickly go back to the first GUI, click "New" and start typing in the "Name" text-box, while the (selected) removed DC disappears from the grid in the background]. 

if still difficult to reproduce for some reason - you may close.
Comment 4 Greg Sheremeta 2014-05-30 18:04:02 EDT
Tried really hard to duplicate, but could not. I think we're good. Thanks!

Note You need to log in before you can comment on or make changes to this bug.