Bug 1015283 - rpcbind terminates with an error when unit is stopped
rpcbind terminates with an error when unit is stopped
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpcbind (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 15:38 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2014-11-18 07:08 EST (History)
2 users (show)

See Also:
Fixed In Version: rpcbind-0.2.1-4.0.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 07:08:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2013-10-03 15:38:46 EDT
Description of problem:
During shutdown rpcbind.service prints ugly warnings:

Oct 03 21:25:29 fedora systemd[1]: Stopping RPC bind service...
Oct 03 21:25:29 fedora rpcbind[589]: rpcbind terminating on signal. Restart with "rpcbind -w"
Oct 03 21:25:29 fedora systemd[1]: rpcbind.service: main process exited, code=exited, status=2/INVALIDARGUMENT
Oct 03 21:25:29 fedora systemd[1]: Stopped RPC bind service.
Oct 03 21:25:29 fedora systemd[1]: Unit rpcbind.service entered failed state.

Version-Release number of selected component (if applicable):
rpcbind-0.2.1-0.1.fc21.x86_64
systemd-208

How reproducible:
100%

Steps to Reproduce:
1. systemctl stop rpcbind
2. look at the logs

Expected results:
Silent shutdown, with messages at most at info priority.
Comment 1 Marcos Mello 2014-04-21 08:03:33 EDT
Until the daemon is fixed, SuccessExitStatus=2. At least systemd will not consider it is in failed state.
Comment 2 Steve Dickson 2014-10-23 14:04:48 EDT
So restarts and yum updates work rpcbind has to be started with -w 
flag which causes all the current port and service state to be
written to a file. So when that file does not exist
during start up, it should be logged.
Comment 3 Zbigniew Jędrzejewski-Szmek 2014-10-23 18:31:18 EDT
Sure, the advice to use -w might be solid, this bug is not about that. The problem is that the unit should start and terminate cleanly. So either the daemon or the unit or both should be adjusted so this happens.
Comment 4 Fedora Update System 2014-10-27 11:38:51 EDT
rpcbind-0.2.1-3.0.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2014-13642/rpcbind-0.2.1-3.0.fc21
Comment 5 Fedora Update System 2014-10-28 06:08:10 EDT
Package rpcbind-0.2.1-3.0.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpcbind-0.2.1-3.0.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13642/rpcbind-0.2.1-3.0.fc21
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-11-10 12:57:45 EST
rpcbind-0.2.1-4.0.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/rpcbind-0.2.1-4.0.fc21
Comment 7 Fedora Update System 2014-11-18 07:08:47 EST
rpcbind-0.2.1-4.0.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.