Bug 10153 - Install RH 6.1 fails with DYNAMIC LINKER error
Install RH 6.1 fails with DYNAMIC LINKER error
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Depends On:
  Show dependency treegraph
Reported: 2000-03-13 16:46 EST by pausmith
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-06-12 14:24:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description pausmith 2000-03-13 16:46:46 EST
I'm trying to isntall RH 6.1 on a dual-pentium pro system (Super P6DNF).
This system has an IDE 4G harddisk on the IDE1 master and an ATAPI CDROM on
IDE1 slave.  IDE2 is empty.  It also has a floppy and a DAC960 RAID system

I tried to install RH 6.0 on this system and it installed, but I got all
kinds of strange errors; running rpm -V after installation revealed a large
number of MD5 checksum errors, including such diverse (and important)
packages as cpp and libc.so!  I could only get it to install and boot at
all (even with checksum errors) if I didn't install the DAC960 modules.
Also, it seemed to choose to boot an SMP version of the kernel and that
seemed _very_ flakey; if I changed LILO to boot the non-SMP version it
worked much better after install, but the install was still screwed up.

I decided to try RH 6.1 instead, since it uses a later kernel, etc., but
now I can't get it to boot at _all_.  I boot off the CDROM and it comes up
with the "hello" screen.  If I choose the standard install it detects the
DAC960 and then at the bottom of that same screen it immediately dies with
  BUG IN DYNAMIC LINKER ld.so: ../sysdeps/i386/dl-machine.h: 391:
elf_machine_lazy_rel: assertion `((reloc->r_info) & 0xff) == 7' failed

Then it unmounts some things and says I may reboot safely.

So, I tried to boot in expert mode.  Here I choose "Cancel" when asked
about device driver disks and say "Done" immediately when asked about other
drivers, so it doesn't try to detect the DAC960.  It asks me language info,
then detects my CDROM, then immediately dies at the bottom of that screen
with this error:
  python: error in loading shared libraries: /lib/libc.so.6: undefined
symbol: xdr5_u_short, version GLIBC_2.0

If I use ALT-F2 to switch to a shell prompt just before the screen asking
about a CDROM, then I can use shell builtin commands but I can't run any
non-shell command like df, ls, etc. because they all die with the first
error above, the "BUG IN DYNAMIC LINKER" error.

I'm pretty much stuck here, I can't see any way forward.  Any ideas?

BTW, someone else installed this RH6.1 disk on a different system so the
disk seems OK; no one else ever tried this RH6.0 disk.
Comment 1 Jay Turner 2000-03-21 15:09:59 EST
Where did the installation media that you are using come from??  I have not seen
any of these problems and am not able to replicate that in the lab, so I am
tending to think that you have corrupt media.
Comment 2 pausmith 2000-03-31 11:04:59 EST
Both my RH 6.0 and 6.1 media is official RedHat CDs, directly from

I now suspect either a kernel or hardware error.

I loaded an old copy of Debian 2.0 on this system, which ships
with kernel 2.0.34, and it installed flawlessly.  I then proceeded
to upgrade it first to Debian 2.1, then to Debian 2.2 (potato frozen).
It all worked great.

Then I downloaded Linux 2.2.14, compiled it, and booted, and many
invocations of bash died a horrible death with weird heap
errors, internal consistency check errors, etc.  Note that bash
is the default shell, so the system can't boot because many of the
init scripts won't run!

I reboot back into my 2.0.34 kernel, with everything else exactly
the same, and it works fine.  Boot back into 2.2.14, it dies again.

I downloaded 2.3.99 last week, same problem (although actually
it seemed a little better; not so many scripts failed, but the
system still can't boot correctly).

I tried recompiled with GCC 2.7.2 instead of 2.95.2, but still
got the same problem.

I'm suspecting a kernel problem on my hardware, since kernel
2.0.x seems to work, and FreeBSD has been loaded on this system
in the past and that worked, too.

Note You need to log in before you can comment on or make changes to this bug.