Bug 1015317 - Evolution internal editor - Quoted text truncated
Evolution internal editor - Quoted text truncated
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 18:17 EDT by Alex. H. F.
Modified: 2013-10-04 01:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 01:17:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 709409 None None None Never

  None (edit)
Description Alex. H. F. 2013-10-03 18:17:07 EDT
Description of problem:

Evolution starts normally.
All tasks run normally (show mail folders, e-mails get retrieved, etc)
Quoted-text truncated at first answered message after startup.


Version-Release number of selected component (if applicable):
3.8.5
Same behaviour since 3.6.? (Fedora 18)


How reproducible:
Always


Steps to Reproduce:
1. Start Evolution
2. Answer an existing message
3. Internal Editor starts


Actual results:
At first answered Message:
Quoted text gets shown shortly (fraction of a second) correct, but then it gets truncated at beginning (dashed line + first lines).

At subsequent answered messages:
Quoted text gets shown correctly. No problem.


Expected results:
No truncation of the quoted text when answering for the first time after Evolution start.


Additional info:
I could find out that it relates to the option:

"Signatur beim Antworten über der Original-Nachricht behalten"
(Keep signature above the original-message)

If this option is "on", problem occurs. No problem when the option is "off".

Problem occurs independently of settings like "HTML/plain text", "different kinds of quotation".

The issue might relate to the handling of signatures.
Editor could paste signature-holder (even if empty) at wrong place, not at beginning of text.


Example of damaged quoted text:

-
------- Weitergeleitete Nachricht --------A
n: anyone@anywhere.orgD
atum: Thu, 26 Sep 2013 10:16:26 +0000h
ttps://bugzilla.redhat.com/show_bug.cgi?id=XXXXXX-
-- Comment #XX from Anyone Outthere <anyone@anywhere.org> ---m
entioning "noveau" (didn't know what that was at the time).I
 have dual screens, and had switched from fullscreen to windowed a couple of
times. But the crash came minutes later.. (entire computer lock down, not even
the num-lock indicator on the keyboard worked).
Comment 1 Milan Crha 2013-10-04 01:17:44 EDT
Thanks for a bug report. I can reproduce this with latest git master, which is quite the same as current stable, 3.10.0, in this part, and the interesting thing is that it does that cutting with the first reply only. The second on the same email works just fine.

As this is not Fedora specific, I moved this to upstream [1]. Please see [1] for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=709409

Note You need to log in before you can comment on or make changes to this bug.