Bug 1015332 - python-gnutls isn't tracking the gnutls version
python-gnutls isn't tracking the gnutls version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-gnutls (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 19:50 EDT by Andy Lutomirski
Modified: 2017-06-09 14:56 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-gnutls-1.2.4-2.fc19 python-gnutls-3.1.1-1.fc25 python-gnutls-3.1.1-1.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-22 20:39:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix gnutls version and extras (12.45 KB, text/plain)
2013-10-21 17:06 EDT, Nathanael Noblet
no flags Details
Remove gnutls extras, update library version loaded, adjust openpgp function test (13.26 KB, text/plain)
2013-10-26 08:51 EDT, Nathanael Noblet
no flags Details

  None (edit)
Description Andy Lutomirski 2013-10-03 19:50:21 EDT
python-gnutls-1.2.4-1.fc19.x86_64's /usr/lib64/python2.7/site-packages/gnutls/library/__init__.py contains:

libgnutls = load_library(name='gnutls', version=26)

But gnutls-3.1.11-1.fc19.x86_64 provides /usr/lib/libgnutls.so.28.  This causes errors like this:

>>> import gnutls.crypto
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/gnutls/crypto.py", line 11, in <module>
    from gnutls.validators import method_args, one_of
  File "/usr/lib64/python2.7/site-packages/gnutls/validators.py", line 9, in <module>
    from gnutls.constants import *
  File "/usr/lib64/python2.7/site-packages/gnutls/constants.py", line 38, in <module>
    from gnutls.library import constants
  File "/usr/lib64/python2.7/site-packages/gnutls/library/__init__.py", line 120, in <module>
    libgnutls = load_library(name='gnutls', version=26)
  File "/usr/lib64/python2.7/site-packages/gnutls/library/__init__.py", line 54, in load_library
    raise RuntimeError('cannot find lib%s on this system' % name)
RuntimeError: cannot find libgnutls on this system

I'm not sure what the right fix is (make python-gnutls require the particular soname?), but this make the package useless.
Comment 1 Richard Wall 2013-10-11 10:21:27 EDT
Same problem here (I think) while trying to run Blink using Fedora provided gnutls bindings.
 * http://icanblink.com/


Fedora 19


(blink)[richard@zorin blink-0.5.0]$ blink
Traceback (most recent call last):
  File "/home/richard/.virtualenvs/blink/bin/blink", line 8, in <module>
    execfile(__file__)
  File "/home/richard/projects/Blink/blink-0.5.0/bin/blink", line 24, in <module>
    from blink import Blink
  File "/home/richard/projects/Blink/blink-0.5.0/blink/__init__.py", line 28, in <module>
    from gnutls.crypto import X509Certificate, X509PrivateKey
  File "/usr/lib64/python2.7/site-packages/gnutls/crypto.py", line 11, in <module>
    from gnutls.validators import method_args, one_of
  File "/usr/lib64/python2.7/site-packages/gnutls/validators.py", line 9, in <module>
    from gnutls.constants import *
  File "/usr/lib64/python2.7/site-packages/gnutls/constants.py", line 38, in <module>
    from gnutls.library import constants
  File "/usr/lib64/python2.7/site-packages/gnutls/library/__init__.py", line 120, in <module>
    libgnutls = load_library(name='gnutls', version=26)
  File "/usr/lib64/python2.7/site-packages/gnutls/library/__init__.py", line 54, in load_library
    raise RuntimeError('cannot find lib%s on this system' % name)
RuntimeError: cannot find libgnutls on this system


(blink)[richard@zorin blink-0.5.0]$ yum  list installed | egrep -i gnutls
gnutls.x86_64                       3.1.11-1.fc19               installed
gnutls-c++.x86_64                   3.1.11-1.fc19               installed
gnutls-dane.x86_64                  3.1.11-1.fc19               installed
gnutls-devel.x86_64                 3.1.11-1.fc19               installed
python-gnutls.x86_64                1.2.4-1.fc19                @fedora
Comment 2 Nathanael Noblet 2013-10-21 17:06:20 EDT
Created attachment 814808 [details]
Patch to fix gnutls version and extras

There are a couple problems I've run into on this.  it hardcodes to 26 instead of 28 also it tries to include gnutls-extra which doesn't exist anymore. The following patch fixes both for me...


I should also point out that python-gnutls seems to be dead and a new project pygnutls is around. Though they're at the same version and have the same bug currently...

I found the above patch via https://bugs.archlinux.org/task/30363
Comment 3 Nathanael Noblet 2013-10-26 08:51:14 EDT
Created attachment 816391 [details]
Remove gnutls extras, update library version loaded, adjust openpgp function test

This updated patch fixes the mismatched version loading, removes the functions that were in gnutls extras which no longer exists and adjusts the openpgp function test in library/functions.py that no longer exists. This allows python-gnutls to actually be used. I've tested it with a mandos server which uses it and the openpgp functions. Not 100% that it couldn't somehow be missing something with the openpgp functions in library/functions.py however I would have expected an exception if that were the case. Regardless if it does somehow break openpgp for some use cases, they were never working as is anyway at least not with the latest gnutls version anyway.
Comment 4 Fedora Update System 2013-11-08 13:13:28 EST
python-gnutls-1.2.4-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-gnutls-1.2.4-2.fc19
Comment 5 Fedora Update System 2013-11-08 13:13:39 EST
python-gnutls-1.2.4-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-gnutls-1.2.4-3.fc20
Comment 6 Fedora Update System 2013-11-08 22:35:05 EST
Package python-gnutls-1.2.4-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-gnutls-1.2.4-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20978/python-gnutls-1.2.4-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-11-17 21:56:43 EST
python-gnutls-1.2.4-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-11-17 21:57:30 EST
python-gnutls-1.2.4-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Taras 2017-05-12 06:44:49 EDT
Have this error in Fedora 25.
Comment 10 Fedora Update System 2017-05-12 12:00:38 EDT
python-gnutls-3.1.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-478ad5a8b3
Comment 11 Fedora Update System 2017-05-12 12:00:45 EDT
python-gnutls-3.1.1-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b29150a7f7
Comment 12 Fedora Update System 2017-05-15 02:34:43 EDT
python-gnutls-3.1.1-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b29150a7f7
Comment 13 Fedora Update System 2017-05-15 06:19:51 EDT
python-gnutls-3.1.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-478ad5a8b3
Comment 14 Fedora Update System 2017-05-22 20:39:23 EDT
python-gnutls-3.1.1-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2017-06-09 14:56:27 EDT
python-gnutls-3.1.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.