Bug 1015354 - Simulation engine did not return any results if there is a subprocess
Simulation engine did not return any results if there is a subprocess
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
All All
high Severity high
: ER5
: 6.0.0
Assigned To: Maciej Swiderski
Tomas Livora
:
: 1015416 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 22:20 EDT by Xu Degui
Modified: 2014-08-06 16:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:07:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Detailed issue description and steps to reproduce (642.79 KB, application/exe)
2013-10-03 22:20 EDT, Xu Degui
no flags Details

  None (edit)
Description Xu Degui 2013-10-03 22:20:58 EDT
Created attachment 807345 [details]
Detailed issue description and steps to reproduce

Description of problem:
Create a simple process with subprocess. Execute process simulation and it returns message "Simulation Engine did not return results". Simulation works fine when there is no subprocess.

Version-Release number of selected component (if applicable):
6.0.0 ER3

How reproducible:
Always reproducible. Please refer to the attached document "bpms6-simulation-issue.pdf".

Steps to Reproduce:
1. Create a simple process named "ManagersReview" with the following steps:
Start -> Human Task -> End
2. Create another process named "PerformanceReview" and include "ManagersReview" as a subprocess in it.
3. Execute process simulation for "PerformanceReview" process.

Actual results:
Message "Simulation Engine did not return results".

Expected results:
Simulation should run properly and return some statistics.

Additional info:
Comment 2 Kris Verlaenen 2013-10-04 08:45:54 EDT
*** Bug 1015416 has been marked as a duplicate of this bug. ***
Comment 3 Tihomir Surdilovic 2013-10-04 13:14:47 EDT
Designer UI part (adding simulation properties to subprocess nodes) is in master and 6.0.x branches.
Comment 4 Maciej Swiderski 2013-10-07 10:21:36 EDT
Improved simulation engine handling of subprocesses and imports of custom data that is only present in the project (kjar). Please note that simulation currently will not go through the content of the sub process and only rely on simulation properties for the subprocess regardless of its type. So that means then when specifying simulation properties for subprocess its complete execution should be considered. 

jbpm
master
https://github.com/droolsjbpm/jbpm/commit/f1933aa9f668b02c4712b11da05ea97ce5ee22d3

6.0.x
https://github.com/droolsjbpm/jbpm/commit/71ce88402f12c35b4ab9ba7264b32522db8246b3

droolsjbpm-integration
master
https://github.com/droolsjbpm/droolsjbpm-integration/commit/c5db88202a6faaec8b49bdaaa287a5828531dae1

6.0.x
https://github.com/droolsjbpm/droolsjbpm-integration/commit/b262440ad36c252b8f5e00361b3a1a43ba24a402
Comment 5 Tomas Livora 2013-12-02 10:05:31 EST
Verified on BPMS 6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.