Bug 101538 - Killalling Ur-Quan Masters causes X to crash
Killalling Ur-Quan Masters causes X to crash
Status: CLOSED DUPLICATE of bug 73733
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-03 06:14 EDT by Need Real Name
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X server config (3.80 KB, text/plain)
2003-08-10 16:58 EDT, Need Real Name
no flags Details
Log after the crash (36.49 KB, text/plain)
2003-08-10 16:58 EDT, Need Real Name
no flags Details
Log before the crash (31.64 KB, text/plain)
2003-08-10 16:59 EDT, Need Real Name
no flags Details
lsmod output before the crash (1.25 KB, text/plain)
2003-08-10 16:59 EDT, Need Real Name
no flags Details
/var/log/messages before the crash (201.95 KB, text/plain)
2003-08-10 17:01 EDT, Need Real Name
no flags Details
/var/log/messages after the crash (203.42 KB, text/plain)
2003-08-10 17:01 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-08-03 06:14:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When I run the game Ur-Quan Masters, jump to another virtual com to killall it,
then back to X, and wait a few second, the X crashes.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. install Ur-Quan masters (from the Fedora Project testing branch)
2. Run Ur-Quan Masters (uqm -f)
3. Jump to another virtual console
4. killall uqm
5. Jump back to X
6. X crashes

Actual Results:  X shutdown and restarted.

Expected Results:  X kept on going.

Additional info:

Ur-Quan Masters can be downloaded from
http://download.fedora.us/fedora/redhat/9/i386/RPMS.testing/
(install all the uqm-* packages).

Everything works fine if I omit the -f option, but the contrast between the
black gamescreen and the bright desktop makes it hard to see what's happening.

I'm using the nvidia binary driver from NVIDIA's home page, so it could be a
problem with that too.

The last few lines from the log (the only ones after startup messages):


(II) NVIDIA(0): Setting mode "640x480"
SwitchToMode - Succeeded
GetModeLine - scrn: 0 clock: 37200
GetModeLine - hdsp: 640 hbeg: 672 hend: 752 httl: 864
              vdsp: 480 vbeg: 480 vend: 482 vttl: 505 flags: 0
GetModeLine - scrn: 0 clock: 37200
GetModeLine - hdsp: 640 hbeg: 672 hend: 752 httl: 864
              vdsp: 480 vbeg: 480 vend: 482 vttl: 505 flags: 0
SwitchToMode - scrn: 0 clock: 121500
               hdsp: 1152 hbeg: 1216 hend: 1344 httl: 1568
               vdsp: 864 vbeg: 865 vend: 868 vttl: 911 flags: 0
Checking against clock: 121500 (121500)
                 hdsp: 1152 hbeg: 1216 hend: 1344 httl: 1568
                 vdsp: 864 vbeg: 865 vend: 868 vttl: 911 flags: 0
(II) Open APM successful
(II) NVIDIA(0): Setting mode "640x480"
(II) DevInputMice: ps2EnableDataReporting: succeeded
(II) Mouse0: ps2EnableDataReporting: succeeded
 
   *** If unresolved symbols were reported above, they might not
   *** be the reason for the server aborting.
 
Fatal server error:
Caught signal 11.  Server aborting
 
 
When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.
Comment 1 Mike A. Harris 2003-08-03 17:39:50 EDT

*** This bug has been marked as a duplicate of 73733 ***
Comment 2 Need Real Name 2003-08-07 03:25:45 EDT
No, as a matter of fact this is not an NVIDIA binary driver -specific problem.
It happens with the "nv" driver (which came with Red Hat) as well.
Comment 3 Mike A. Harris 2003-08-08 18:14:46 EDT
Attach your X server log and config file using the "nv" driver using bugzilla
file attachment feature.  Do this from a fresh reboot of the system without ever
loading the nvidia binary driver module or any other 3rd party kernel modules.

Please also attach the output of "lsmod" from within an xterm in XFree86 prior
to running the game with the "nv" driver, and also attach your /var/log/messages
file which may provide clues.

Thanks.
Comment 4 Need Real Name 2003-08-10 16:58:14 EDT
Created attachment 93555 [details]
X server config
Comment 5 Need Real Name 2003-08-10 16:58:54 EDT
Created attachment 93556 [details]
Log after the crash
Comment 6 Need Real Name 2003-08-10 16:59:24 EDT
Created attachment 93557 [details]
Log before the crash
Comment 7 Need Real Name 2003-08-10 16:59:50 EDT
Created attachment 93558 [details]
lsmod output before the crash
Comment 8 Need Real Name 2003-08-10 17:01:25 EDT
Created attachment 93559 [details]
/var/log/messages before the crash
Comment 9 Need Real Name 2003-08-10 17:01:55 EDT
Created attachment 93560 [details]
/var/log/messages after the crash
Comment 10 Mike A. Harris 2003-08-12 04:26:09 EDT
Your X server installation is not "pure".  The Nvidia binary driver installation
has deleted or overwritten various modules that ship with Red Hat Linux with
Nvidia replacements, including GLcore and others.  This is evidenced by some
of the warning/error messages in your X server log file.

Before I can investigate this further, I'll require that you do a fresh
installation of all XFree86 RPM packages that come with the distribution, thus
overwriting all of Nvidia's proprietary X server modules and removing them from
the equation entirely.  You can use the --force commandline option to force
rpm to reinstall already installed (but damaged) packages.

Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a
is unresolved!
Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a
is unresolved!
[SNIP]
(EE) [GLX]: Failed to add GLX extension (NVIDIA XFree86 driver not found)
Comment 11 Mike A. Harris 2003-09-29 16:56:19 EDT
Reclosing as dupe of nvidia binary only bug report.

*** This bug has been marked as a duplicate of 73733 ***
Comment 12 Red Hat Bugzilla 2006-02-21 13:57:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.