Bug 1015405 - IOError: [Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/kobo/client/default.conf'
IOError: [Errno 2] No such file or directory: '/usr/lib/python2.7/site-packag...
Status: CLOSED DUPLICATE of bug 997735
Product: Fedora
Classification: Fedora
Component: kobo (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Mach
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 545868
  Show dependency treegraph
 
Reported: 2013-10-04 03:08 EDT by Jan Hutař
Modified: 2013-10-04 03:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 03:22:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-10-04 03:08:24 EDT
Description of problem:
When using beaker-client to submit updated test to Beaker instance, I get this traceback.


Version-Release number of selected component (if applicable):
kobo-client-0.4.0-1.fc19.noarch
beaker-client-0.14.1-1.fc18.noarch


How reproducible:
always


Steps to Reproduce:
1. Use beaker-client to submit updated test to Beaker server


Actual results:
[...]
+ cd /mnt/testarea/rhts-build-EpX3YOZN/rpm-build
+ cd my-test-1.0
+ '[' /home/pok/rpmbuild/BUILDROOT/my-test-1.0-8.x86_64 '!=' / ']'
+ '[' -d /home/pok/rpmbuild/BUILDROOT/my-test-1.0-8.x86_64 ']'
+ rm -rf /home/pok/rpmbuild/BUILDROOT/my-test-1.0-8.x86_64
+ exit 0
/mnt/testarea/rhts-build-EpX3YOZN/install ~/Checkouts/GIT/my-test
Traceback (most recent call last):
  File "/usr/bin/bkr", line 9, in <module>
    load_entry_point('bkr.client==0.14.1', 'console_scripts', 'bkr')()
  File "/usr/lib/python2.7/site-packages/bkr/client/main.py", line 50, in main
    return cmd.run(*cmd_args, **cmd_opts.__dict__)
  File "/usr/lib/python2.7/site-packages/bkr/client/commands/cmd_task_add.py", line 68, in run
    self.set_hub(**kwargs)
  File "/usr/lib/python2.7/site-packages/bkr/client/__init__.py", line 34, in set_hub
    self.container.set_hub(username, password)
  File "/usr/lib/python2.7/site-packages/kobo/client/__init__.py", line 113, in set_hub
    self.hub = HubProxy(conf=self.conf)
  File "/usr/lib/python2.7/site-packages/kobo/client/__init__.py", line 142, in __init__
    self._conf.load_from_file(default_config)
  File "/usr/lib/python2.7/site-packages/kobo/conf.py", line 117, in load_from_file
    fo = open(file_name, "r")
IOError: [Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/kobo/client/default.conf'
Exception AttributeError: AttributeError("'HubProxy' object has no attribute '_transport'",) in <bound method HubProxy.__del__ of <kobo.client.HubProxy object at 0x7fcaf1755750>> ignored
make: *** [bkradd] Error 1
rm testinfo.desc


Expected results:
Should work.


Additional info:
When I have touched /usr/lib/python2.7/site-packages/kobo/client/default.conf file, it started working.
Comment 1 Dan Callaghan 2013-10-04 03:22:01 EDT

*** This bug has been marked as a duplicate of bug 997735 ***

Note You need to log in before you can comment on or make changes to this bug.