Bug 1015414 - pcscd broken
pcscd broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pcsc-lite (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Bob Relyea
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 03:51 EDT by George Voina
Modified: 2013-10-04 03:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 03:55:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Voina 2013-10-04 03:51:09 EDT
Again the problem I had in Fedora 17 resurfaced after update to Fedora 19.
Service pcscd is not able to add the Aladdin (SmartNet) smart card.


Oct  4 10:45:32 localhost systemd[1]: Started PC/SC Smart Card Daemon.
Oct  4 10:45:32 localhost pcscd[21497]: 00000000 utils.c:53:GetDaemonPid() Can't open /var/run/pcscd/pcscd.pid: No such file or directory
Oct  4 10:45:32 localhost pcscd[21497]: 00001678 dyn_unix.c:81:DYN_GetAddress() IFDHCreateChannelByName: /usr/lib64/pcsc/drivers/openct-ifd.bundle/Contents/Linux/openct-ifd.so: undefined symbol: IFDHCreateChannelByName
Oct  4 10:45:32 localhost pcscd[21497]: Error: can't open /var/run/openct/status: No such file or directory
Oct  4 10:45:32 localhost pcscd[21497]: 00000083 readerfactory.c:1009:RFInitializeReader() Open Port 0x200000 Failed (usb:0529/0600:libudev:0:/dev/bus/usb/003/037)
Oct  4 10:45:32 localhost pcscd[21497]: 00000003 readerfactory.c:312:RFAddReader() Aladdin eToken PRO 64 init failed.
Oct  4 10:45:32 localhost pcscd[21497]: 00000073 hotplug_libudev.c:384:HPAddDevice() Failed adding USB device: Aladdin eToken PRO 64

From what I remember in Fedora 17 the bug was due to the broken usb bus resulting in pcscd being unable to lock the USB device (smart card).

I mention that if openct is used instead of pcscd the result is:
[root@localhost config]# openct-tool list
  0 Aladdin eToken PRO 64k

The smart card works perfectly. Because pcscd is not working I cannot init a new token with certificates, but I can use without problems with openct an already initialized token.
Comment 1 George Voina 2013-10-04 03:55:53 EDT
Found that the problem is due to the order the services were started.
service openct start 
service pcscd start 

if started in this order then problem is fixed.

Note You need to log in before you can comment on or make changes to this bug.