Bug 1015423 - DB Schema creation fails in 30% -to- 100% of installers runs (timing issue - the slower the machine, the more likely the failure)
DB Schema creation fails in 30% -to- 100% of installers runs (timing issue - ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER4
: ---
Assigned To: Thomas Hauser
Len DiMaggio
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 04:14 EDT by Jiri Sedlacek
Modified: 2015-08-02 19:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 03:28:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sqlresults.log (6.67 KB, text/x-log)
2013-10-04 04:14 EDT, Jiri Sedlacek
no flags Details

  None (edit)
Description Jiri Sedlacek 2013-10-04 04:14:30 EDT
Created attachment 807482 [details]
sqlresults.log

I tried to run installer several times, just specified install dir and passwords, everything else was set to default values, didn't perform any aditional configuration steps.

Installation fails in 3 to 5 from 10 tries, with problem in db schema creation.

sqlresults.log is attached. (there are some czech sentences because of my locale, if you need translation, please let me know).
Comment 1 Thomas Hauser 2013-10-04 11:31:17 EDT
I am unable to reproduce this even reinstalling many times in a row with default (h2) settings. Out of 10 installs, 10 succeed using the most recent installer.
Comment 3 Jiri Sedlacek 2013-10-07 03:28:49 EDT
Tested with current version of installer and cannot reproduce, so closing as not a bug.
Comment 4 Jiri Sedlacek 2013-10-07 03:34:22 EDT
My mistake, just one more run shows the same problem. Can there be some timing issue?
Comment 7 Jiri Sedlacek 2013-10-08 04:44:13 EDT
Confirmed on second machine, similar hardware as mine.
Comment 8 Len DiMaggio 2013-10-08 11:56:27 EDT
I am seeing this 100% of the time on a Windows VM
Comment 9 Thomas Hauser 2013-10-09 14:04:17 EDT
The fix for this now involves reading the stream for an appropriate code from the server, and only then advancing the installation.
Comment 10 Len DiMaggio 2013-10-18 10:11:43 EDT
Verified on ER4 and ER6

Note You need to log in before you can comment on or make changes to this bug.