Bug 1015434 - RPM: Different domain profile file domain/configuration/host.xml
RPM: Different domain profile file domain/configuration/host.xml
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: RPMs (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Permaine Cheung
Katerina Novotna
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 05:01 EDT by Pavel Janousek
Modified: 2015-02-20 06:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 09:28:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff output (3.43 KB, text/plain)
2013-10-07 06:19 EDT, Pavel Janousek
no flags Details

  None (edit)
Description Pavel Janousek 2013-10-04 05:01:02 EDT
RPM for RHEL6 contain different domain profile file domain/configuration/host.xml. Differences are in:
- whitespace (minor)
- closing mark of tag (space between last char and '/>') (minor)
- comments (major)
- missing, although commented out, example section (*) (blocker) 

The only one already approved difference is "<servers directory-grouping="by-type">" (in RPM) vs "<servers>" (in ZIP). Anything else should be treated as unacceptable difference -> blocker.

(*)
>             <!-- Remote JPDA debugging for a specific server
>             <jvm name="default">
>               <jvm-options>
>                 <option value="-agentlib:jdwp=transport=dt_socket,address=8787,server=y,suspend=n"/>
>               </jvm-options>
>            </jvm>
>            -->
Comment 1 Permaine Cheung 2013-10-04 12:50:44 EDT
Hi Pavel,

I am unable to reproduce this, I unzipped the domain/configuration/host.xml file from the ER3 zip and extracted /etc/jbossas/domain/host.xml from jbossas-domain-7.3.0-1.Final_redhat_6.1.ep6.el6.noarch.rpm and the only diff is the approved servers setting.
I also tried starting and stopping the server in domain mode and the only diff that I see is still the approved one:
@@ -82,7 +82,7 @@
        </jvm>
  	</jvms>
 
-    <servers>
+    <servers directory-grouping="by-type">
         <server name="server-one" group="main-server-group">
             <!-- Remote JPDA debugging for a specific server
             <jvm name="default">


Can you please provide exact steps to reproduce this?
Also, please specify NVR when reporting issue against a rpm.
Thanks!
Comment 2 Pavel Janousek 2013-10-07 06:18:56 EDT
Hi Permaine,

I've done a re-check of this issue today with the same result though. I'd compared a ZIP version from ER3 build with /usr/share/jbossas/domain/configuration/host.xml file comes from jbossas-domain-7.3.0-1.Final_redhat_6.1.ep6.el6.noarch (ER3 RPM).

The full diff output is as the attachment.
Comment 3 Pavel Janousek 2013-10-07 06:19:49 EDT
Created attachment 808767 [details]
Diff output
Comment 4 Permaine Cheung 2013-10-08 12:20:39 EDT
Is this compared against a pristine rpm installation? Does rpm -qV jbossas-domain indicates that /etc/jbossas/domain/host.xml has changed after it is installed?
Comment 5 Fernando Nasser 2013-10-15 17:18:54 EDT
Please provide more info, we cannot reproduce this.
Comment 6 Pavel Janousek 2013-10-22 09:18:55 EDT
I've re-checked it with ER5 RPM set, unfortunately I couldn't use the older bits again due to the nature of RHN Stage. For ER5 I can't reproduce this issue, everything looks fine on pristine installation (strictly followed procedure from Installation Guide).

@Permaine
rpm -qV jbossas-domain report no issue for /etc/jbossas/domain/host.xml.

I'm fine to close this as NOTABUG.
Comment 7 Fernando Nasser 2013-10-22 09:28:41 EDT
Thanks for checking Pavel.

Note You need to log in before you can comment on or make changes to this bug.