Bug 1015437 - SELinux blocks openlmi-networking from reading /proc/net/dev
SELinux blocks openlmi-networking from reading /proc/net/dev
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 05:05 EDT by Radek Novacek
Modified: 2016-11-30 19:31 EST (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-91.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:44:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Novacek 2013-10-04 05:05:24 EDT
Description of problem:
openlmi-networking fails to read /proc/net/dev file because it's blocked by selinux. openlmi-networking takes network device statistics out of this file.

Version-Release number of selected component (if applicable):
selinux-policy-3.12.1-86.el7

AVC follows:

time->Fri Oct  4 12:57:36 2013
type=SYSCALL msg=audit(1380884256.792:465): arch=c000003e syscall=2 success=no exit=-13 a0=7f0439e435dc a1=0 a2=1b6 a3=0 items=0 ppid=1 pid=2137 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="cimprovagt" exe="/usr/libexec/pegasus/cimprovagt" subj=system_u:system_r:pegasus_openlmi_system_t:s0 key=(null)
type=AVC msg=audit(1380884256.792:465): avc:  denied  { read } for  pid=2137 comm="cimprovagt" name="dev" dev="proc" ino=4026531975 scontext=system_u:system_r:pegasus_openlmi_system_t:s0 tcontext=system_u:object_r:proc_net_t:s0 tclass=file
----
Comment 2 Miroslav Grepl 2013-10-16 05:38:18 EDT
commit a3ca57a681a4a7a5aed5eed3cd49db2e034648e0
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Wed Oct 16 11:38:01 2013 +0200

    Allow openlmi-networking to read /proc/net/dev
Comment 4 Ludek Smid 2014-06-13 08:44:45 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.