Bug 1015443 - [abrt] evolution-3.10.0-1.fc20: _g_log_abort: Process /usr/bin/evolution was killed by signal 6 (SIGABRT)
[abrt] evolution-3.10.0-1.fc20: _g_log_abort: Process /usr/bin/evolution was ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:14b6fc7277dc749e9b909130276...
:
: 1080046 1086679 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 05:24 EDT by Adam Williamson
Modified: 2014-04-14 08:15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 13:45:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (144.13 KB, text/plain)
2013-10-04 05:24 EDT, Adam Williamson
no flags Details
File: cgroup (145 bytes, text/plain)
2013-10-04 05:24 EDT, Adam Williamson
no flags Details
File: core_backtrace (130.27 KB, text/plain)
2013-10-04 05:24 EDT, Adam Williamson
no flags Details
File: dso_list (25.16 KB, text/plain)
2013-10-04 05:24 EDT, Adam Williamson
no flags Details
File: environ (1.53 KB, text/plain)
2013-10-04 05:24 EDT, Adam Williamson
no flags Details
File: limits (1.29 KB, text/plain)
2013-10-04 05:24 EDT, Adam Williamson
no flags Details
File: maps (159.52 KB, text/plain)
2013-10-04 05:25 EDT, Adam Williamson
no flags Details
File: open_fds (1.59 KB, text/plain)
2013-10-04 05:25 EDT, Adam Williamson
no flags Details
File: proc_pid_status (949 bytes, text/plain)
2013-10-04 05:25 EDT, Adam Williamson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 709441 None None None Never

  None (edit)
Description Adam Williamson 2013-10-04 05:24:35 EDT
Description of problem:
Had just resumed from suspend, Evo was refreshing all mail, crashed in the middle.

Version-Release number of selected component:
evolution-3.10.0-1.fc20

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/bin/evolution
crash_function: _g_log_abort
executable:     /usr/bin/evolution
kernel:         3.12.0-0.rc3.git2.2.fc21.x86_64
runlevel:       N 5
type:           CCpp
uid:            1001
var_log_messages: Oct  4 10:01:38 vaioz abrt[3145]: Saved core dump of pid 2005 (/usr/bin/evolution) to /var/tmp/abrt/ccpp-2013-10-04-10:01:35-2005 (512049152 bytes)

Truncated backtrace:
Thread no. 1 (9 frames)
 #2 _g_log_abort at gmessages.c:255
 #5 g_settings_binding_free at gsettings.c:2328
 #6 g_datalist_clear at gdataset.c:277
 #8 handle_mail_request at e-mail-request.c:201
 #9 run_in_thread at gsimpleasyncresult.c:871
 #10 io_job_thread at gioscheduler.c:89
 #11 g_task_thread_pool_thread at gtask.c:1245
 #13 g_thread_proxy at gthread.c:798
 #15 clone at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111
Comment 1 Adam Williamson 2013-10-04 05:24:40 EDT
Created attachment 807514 [details]
File: backtrace
Comment 2 Adam Williamson 2013-10-04 05:24:44 EDT
Created attachment 807515 [details]
File: cgroup
Comment 3 Adam Williamson 2013-10-04 05:24:48 EDT
Created attachment 807516 [details]
File: core_backtrace
Comment 4 Adam Williamson 2013-10-04 05:24:52 EDT
Created attachment 807517 [details]
File: dso_list
Comment 5 Adam Williamson 2013-10-04 05:24:55 EDT
Created attachment 807518 [details]
File: environ
Comment 6 Adam Williamson 2013-10-04 05:24:58 EDT
Created attachment 807519 [details]
File: limits
Comment 7 Adam Williamson 2013-10-04 05:25:03 EDT
Created attachment 807520 [details]
File: maps
Comment 8 Adam Williamson 2013-10-04 05:25:06 EDT
Created attachment 807521 [details]
File: open_fds
Comment 9 Adam Williamson 2013-10-04 05:25:09 EDT
Created attachment 807522 [details]
File: proc_pid_status
Comment 10 Milan Crha 2013-10-04 13:45:13 EDT
Thanks for a bug report. The log message says:
   g_settings_binding_free: assertion failed: (!binding->running)

From that I'd say either:
a) bug in glib/gsettings (unlikely)
b) memory corruption caused by evolution/-data-server (likely)

I moved this upstream as [1], under evolution. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=709441
Comment 11 Milan Crha 2014-03-25 04:21:04 EDT
*** Bug 1080046 has been marked as a duplicate of this bug. ***
Comment 12 Milan Crha 2014-04-14 08:15:25 EDT
*** Bug 1086679 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.