Bug 1015455 - [RHSC] - Rebalance icon in the activities column disappears once rebalance is run sucessfully.
[RHSC] - Rebalance icon in the activities column disappears once rebalance is...
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kanagaraj
storage-qa-internal@redhat.com
:
Depends On:
Blocks: 1035040
  Show dependency treegraph
 
Reported: 2013-10-04 05:53 EDT by RamaKasturi
Modified: 2016-04-18 06:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
The information on successfully completed rebalance volume task is cleared from the Red Hat Storage Console after 5 minutes. The information on failed tasks is cleared after 1 hour.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-26 02:06:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2013-10-04 05:53:06 EDT
Description of problem:
Rebalance icon in the activities column disappears once rebalance is run sucessfully.

Version-Release number of selected component (if applicable):
rhsc-2.1.1-0.0.2.master.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a distributed volume and start it.
2. start rebalance on the volume.
3. Make sure that rebalance compeltes on the volume and there is an icon in the activites column which says that rebalance is completed.
4. Check the activities column after 10 mins.

Actual results:
Rebalance icon disappears from the activites column after 10 mins and clicking on status shows "rebalance has never run on this volume."

Expected results:
Rebalance icon should be present in the activites column and clicking on the status should always show the last status output.


Additional info:
Comment 2 Kanagaraj 2013-10-07 00:32:49 EDT
There are two issues here
1. Rebalance status icon disappeared after 10 mins once its successfully completed

2. Rebalance status gives "Rebalance has never run on this volume"

Issue 2 is already addressed in this patch http://gerrit.ovirt.org/#/c/19864/

For Issue 1, the task details are automatically cleared by the task framework after 10 mins. We need to find out way to retain the task information for a longer time.
Comment 3 Kanagaraj 2013-10-31 03:26:23 EDT
We are using the task framework which cleans up the successfully completed task after 10 minutes.
Comment 4 Dusmant 2013-10-31 06:49:47 EDT
Because of the task framework limitation, it will get cleared up and nothing can be done for this... This has to be documented...
Comment 5 Shalaka 2014-01-28 04:19:30 EST
Please review the edited Doc Text and sign off.
Comment 6 Kanagaraj 2014-02-03 01:23:20 EST
doc_text looks good.
Comment 7 Sahina Bose 2015-03-26 02:06:36 EDT
As per comment 4, closing this

Note You need to log in before you can comment on or make changes to this bug.