Bug 1015505 - Gadget web: Delete of multiple pages causes NumberFormatException in JavaScript console
Gadget web: Delete of multiple pages causes NumberFormatException in JavaScri...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: RT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER7
: 6.0.0
Assigned To: Eric Wittmann
Andrej Vano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 08:11 EDT by Andrej Vano
Modified: 2014-02-06 10:25 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:25:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Vano 2013-10-04 08:11:37 EDT
Description of problem: 
Deleting pages in other order than "newest first" will cause JavaScript exception.
See steps to reproduce.

Version-Release number of selected component (if applicable):
6.0.0.ER4-5


How reproducible: 100%


Steps to Reproduce:
1. Create new pages with names for example "1", "2", "3" (in this order)
2. Delete page "1" and it will be deleted
3. Delete page "2", the page will be still present and the exception will be logged into javascript console
4. The page "2" is still present, but can't be accessed until the refresh of the web-console

Actual results:


Expected results:


Additional info:
Comment 2 Eric Wittmann 2013-10-07 10:47:53 EDT
The gadget server was tracking the (server-side) page ID of a tab using the index of that tab (it's position relative to other tabs).  This was problematic when a tab was deleted, because the mappings would de-synch.  The right way to fix this would be to store the page ID on an attribute in the UI itself, and pass that along when the user clicks the delete button for a tab.  However, the shortest path to fixing this was to simply update the mappings whenever a tab is deleted.

Since we're likely chucking gadget server in the future, in favor of some alternative UI, I went with the shortest path to completion.
Comment 5 Andrej Vano 2013-12-16 04:42:51 EST
Hello,

verified on ER7-2

Note You need to log in before you can comment on or make changes to this bug.