Bug 1015523 - unable to restart app via REST
unable to restart app via REST
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 08:44 EDT by Oleg Fayans
Modified: 2016-11-30 19:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:33:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg Fayans 2013-10-04 08:44:34 EDT
Description of problem:
When I restart an app via REST API the pid of app does not change

Version-Release number of selected component (if applicable):
reproduced on STG (devenv-stage_472), openshift build N 2.0.33

How reproducible:
Always

Steps to Reproduce:
1. rhc app create myapp python-2.6
2. ssh %app_uuid%@myapp cat ./python/run/httpd.pid
3. restart the app using rest request:

curl -k -X POST https://stg.openshift.redhat.com/broker/rest/applications/%app_uuid%/events --user %username%:%password% --data-urlencode event=restart

4. ssh %app_uuid%@myapp cat ./python/run/httpd.pid

Actual results:
The pids in steps 2 and 4 are identical

Expected results:
the pid should change


Additional info:
Comment 1 Mrunal Patel 2013-10-08 14:48:18 EDT
This is expected behavior since we use httpd -k restart. You will notice that the child process pids change when you restart but the main httpd pid will remain the same. Only way to see the pid change is to stop followed by a start.
Comment 2 Jianwei Hou 2013-10-08 21:55:19 EDT
Marks as verified according to comment 1

Note You need to log in before you can comment on or make changes to this bug.