This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1015574 - List of applications is not populated in RHEV-M for guests
List of applications is not populated in RHEV-M for guests
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Vinzenz Feenstra [evilissimo]
Pavel Novotny
virt
:
Depends On:
Blocks: 901415 1019461 3.3snap1
  Show dependency treegraph
 
Reported: 2013-10-04 10:10 EDT by David Jaša
Modified: 2014-01-21 17:32 EST (History)
10 users (show)

See Also:
Fixed In Version: is20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20236 None None None Never
oVirt gerrit 20237 None None None Never

  None (edit)
Description David Jaša 2013-10-04 10:10:31 EDT
Description of problem:
After installation of RHEV Agent in Windows and VM reboot, list of Applications doesn't reach RHEV-M, but guest IP info does (is visible in webadmin & REST API)

Version-Release number of selected component (if applicable):
is16 (but the issue is in previous builds as well):
rhevm-3.3.0-0.23.master.el6ev.noarch
vdsm-4.12.0-156.git6e499d6.el6ev.x86_64
RHEV tools 3.3-6

How reproducible:
always

Steps to Reproduce:
1. create a windows VM, install latest tools, reboot
2. verify guest IP and application list in engine (using webadmin or REST API)
3.

Actual results:
IP is reported but appliation list is empty

Expected results:
both IP and application list are known to RHEV-M

Additional info:
Comment 3 David Jaša 2013-10-04 10:13:51 EDT
Created attachment 807686 [details]
vdsm log: newer
Comment 4 David Jaša 2013-10-04 10:31:38 EDT
CCing Omer (Vinzenz's suggestion).
Comment 5 Vinzenz Feenstra [evilissimo] 2013-10-07 07:08:01 EDT
I have checked the environment and the problem lays somewhere on the engine side. The engine is not displaying the applications reported by the guest agent.
VDSM is reporting all applications, therefore the problem must reside on the engine side. It's not sure however if it the frontend or backend.

@rgolan: Please check if you can find the problem in the engine logs.
Comment 6 David Jaša 2013-10-15 07:43:49 EDT
vdsm log says:
Thread-3287::DEBUG::2013-10-15 13:30:08,253::BindingXMLRPC::981::vds::(wrapper) return vmGetStats with <...> 'appsList': [u'Adobe Flash Player 11 ActiveX', u'Adobe Flash Player 11 Plugin', u'Windows Internet Explorer 8', u'InfraRecorder', u'Windows Genuine Advantage Validation Tool (KB892130)', u'Microsoft Base Smart Card Cryptographic Service Provider Package', u'Windows Management Framework Core', u'Update for Microsoft Windows (KB971513)', u'Microsoft .NET Framework 1.1', u'Microsoft .NET Framework 3.5 SP1', u'Microsoft .NET Framework 4 Client Profile', u'Mozilla Firefox 10.0.6 (x86 en-US)', u'Microsoft Compression Client Pack 1.0 for Windows XP', u'Vim 7.3 (self-installing)', u'VLC media player 2.0.3', u'Microsoft Kernel-Mode Driver Framework Feature Pack 1.9', u'Windows Genuine Advantage Validation Tool (KB892130)', u'Windows Genuine Advantage Notifications (KB905474)', u'Windows Media Format 11 runtime', u'Windows Media Player 11', u'Windows Media Format 11 runtime', u'Windows Media Player 11', u'Microsoft User-Mode Driver Framework Feature Pack 1.0', u'RHEV-Tools 3.3.6', u'Java(TM) 7 Update 5', u'RHEV-Serial 3.3.2', u'WebFldrs XP', u'Microsoft .NET Framework 4 Client Profile', u'Update for Microsoft .NET Framework 4 Client Profile (KB2468871)', u'Update for Microsoft .NET Framework 4 Client Profile (KB2533523)', u'Update for Microsoft .NET Framework 4 Client Profile (KB2600217)', u'RHEV-USB 3.3.2', u'RHEV-Agent 3.3.4', u'Java Auto Updater', u'Skype\u2122 5.3', u'RHEV-Block 3.3.1', u'RHEV-Balloon 3.3.2', u'RHEV-Spice-Agent 3.3.2', u'RHEV-QGA 3.3.2', u'RHEV-Spice 3.3.2', u'RHEV-SSO 3.3.1', u'Microsoft .NET Framework 3.0 Service Pack 2', u'LibreOffice 3.5', u'Microsoft .NET Framework 2.0 Service Pack 2', u'Microsoft .NET Framework 1.1', u'Microsoft .NET Framework 3.5 SP1', u'Update for Microsoft .NET Framework 3.5 SP1 (KB963707)', u'RHEV-Network 3.3.1', u'LibreOffice 3.5 Help Pack (English)']

engine log at default priority says nothing (and the log level can not be changed - bug 1019243), the app_list column of vm_dynamic table for respective VM is empty.
Comment 7 Vinzenz Feenstra [evilissimo] 2013-10-16 08:27:10 EDT
Problem was in the VmDynamic Batchmapper, it did not use the FQDN and the app_list
Comment 9 David Jaša 2013-10-30 07:30:05 EDT
works for me in is20.1.
Comment 10 Pavel Novotny 2013-10-30 08:57:09 EDT
Verified in rhevm-3.3.0-0.28.beta1.el6ev.noarch (is20).

Verification steps:
1. In webadmin create new VM and install Windows 7 x64 with latest RHEV Tools (3.3-6).
2. Install few programs in the VM (Firefox, Google Chrome, ...).
3. Reboot the VM and check in webadmin the Applications VM sub-tab.

Results:
The installed applications are listed:

Google Chrome
Mozilla Firefox 25.0 (x86 en-US)
Mozilla Maintenance Service
RHEV-Agent64 3.3.4
RHEV-Balloon64 3.3.2
RHEV-Block64 3.3.1
RHEV-Network64 3.3.1
RHEV-QGA 3.3.2
RHEV-SCSI64 3.3.2
RHEV-SSO64 3.3.1
RHEV-Serial64 3.3.2
RHEV-Spice-Agent64 3.3.2
RHEV-Spice64 3.3.2
RHEV-Tools 3.3.6
RHEV-USB 3.3.2

The app list matches exactly what VDSM reports to RHEVM:
{{{
vmGetStats with { ..., 'appsList': [u'
Google Chrome', u'Mozilla Firefox 25.0 (x86 en-US)', u'Mozilla Maintenance Service', u'RHEV-Tools 3.3.6', u'RHEV-Balloon64 3.3.2', u'RHEV-Spice-Agent64 3.3
.2', u'RHEV-USB 3.3.2', u'RHEV-SCSI64 3.3.2', u'RHEV-Block64 3.3.1', u'RHEV-Network64 3.3.1', u'RHEV-Agent64 3.3.4', u'RHEV-QGA 3.3.2', u'RHEV-SSO64 3.3.1'
, u'RHEV-Spice64 3.3.2', u'RHEV-Serial64 3.3.2'], ...
}}}
Comment 11 Itamar Heim 2014-01-21 17:32:21 EST
Closing - RHEV 3.3 Released
Comment 12 Itamar Heim 2014-01-21 17:32:25 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.