Bug 1015600 - xmvn creating versioned jar dependencies
xmvn creating versioned jar dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xmvn (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 11:04 EDT by Robert Rati
Modified: 2013-10-07 08:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 08:05:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2013-10-04 11:04:08 EDT
Description of problem:
xmvn is creating versioned requires even if the pom fragment is not listing the package as a compat package.  xmvn should be create unversioned requires even if the filename is versioned.

Version-Release number of selected component (if applicable):
xmvn-1.1.0-1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Stanislav Ochotnicky 2013-10-04 11:25:47 EDT
This can be seen in hadoop build[1] having requires on 'mvn(commons-el:commons-el:1.0)'. 

I just realized that this is caused by apache-commons-el being build when add_maven_depmap added <version> in <jpp> part of fragment as well and XMvn now believing this is a compat mapping. 

I believe a possible workaround without need to rebuild every old package that might have versioned symlinks is warranted in this case. How about ignoring version tag in <jpp> part if the whole fragment is not a valid XML (and is therefore produced by old javapackages-tools that puts <version> everywhere). 

This is not going to affect just commons-el but other packages as well


[1] http://koji.fedoraproject.org/koji/rpminfo?rpmID=4457357
Comment 2 Mikolaj Izdebski 2013-10-07 05:32:55 EDT
I cannot reproduce this.
Please include a (simple) reproducer.
Comment 3 Robert Rati 2013-10-07 08:05:54 EDT
This is a bug in individual packages and not with xmvn.

Note You need to log in before you can comment on or make changes to this bug.