Bug 101562 - "Starting <appname>" localization problems with startup-notification
Summary: "Starting <appname>" localization problems with startup-notification
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: startup-notification (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-03 21:13 UTC by Christian Rose
Modified: 2007-04-18 16:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-03 23:10:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Rose 2003-08-03 21:13:47 UTC
Tested with Swedish locale (sv_SE).

When I start an application in RHL 9, for example Mozilla, I get a message in
the task list telling the application is starting:

  "Starting Webbläsaren Mozilla"


There are several problems with this from a localization point of view:

1) The "Starting" obviously isn't translated into Swedish. This seems pretty
easy to fix, it's probably just a matter of enabling localization in the code,
and using a translation project to attract translators and as a consequence
translations (see
http://developer.gnome.org/doc/tutorials/gnome-i18n/developer.html#tp and
http://www.iro.umontreal.ca/contrib/po/HTML/maintainers.html).

2) Concatenating strings like this rarely ever works in other languages, due to
differences in grammar, word order, and capitalization rules. For example, it
really should be:

  "Startar webbläsaren Mozilla"

in Swedish since Swedish never uses uppercase letters in the middle of sentences
unless it's a name. The Swedish example is just a very simple example, there
most likely are more complex ones involving genders and articles in other
languages. To keep things short, a statement of fact is that sentences can only
ever be properly translated in full (more of this is explained on
http://developer.gnome.org/doc/tutorials/gnome-i18n/developer.html#split-sentences).

Hence, the only proper solution to this problem is to allow every application to
provide its own startup message (similar to how every nautilus view provides its
own "View as" message, for exactly the same reasons).

Comment 1 Havoc Pennington 2003-08-03 23:10:56 UTC
The message is from gnome-desktop:

gnome-desktop-item.c:                   description = g_strdup_printf
(_("Starting %s"), name);

It isn't done with strconcat, fwiw, and it is marked for translation.

In any case, should be addressed upstream, as I don't want to take all the
translations themselves in RH patches anyhow.

Comment 2 Christian Rose 2003-08-06 11:26:38 UTC
Done, http://bugzilla.gnome.org/show_bug.cgi?id=119254


Note You need to log in before you can comment on or make changes to this bug.