Bug 101565 - advertisement problem: "radvd: sendmsg: Invalid argument"
advertisement problem: "radvd: sendmsg: Invalid argument"
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: radvd (Show other bugs)
1.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-03 20:58 EDT by Need Real Name
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-07 14:20:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my radvd config without the comments (221 bytes, text/plain)
2003-08-03 21:00 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-08-03 20:58:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
on a redhat7.3

when in the config file, radvd is set to advertise, i get errors:

this is a debug copy:
]# radvd -u radvd -d 4 -m stderr
[Aug 04 02:53:06] radvd: version 0.7.2 started
[Aug 04 02:53:06] radvd: inet_pton returned 1
[Aug 04 02:53:06] radvd: hardware type for eth0 is 1
[Aug 04 02:53:06] radvd: link layer token length for eth0 is 48
[Aug 04 02:53:06] radvd: prefix length for eth0 is 64
[Aug 04 02:53:06] radvd: interface definition for eth0 is ok
[Aug 04 02:53:06] radvd: sending RA on eth0

[Aug 04 02:53:06] radvd: sendmsg: Invalid argument

[Aug 04 02:53:06] radvd: setting timer: 10.00 secs
[Aug 04 02:53:06] radvd: calling alarm: 9 secs, 999934 usecs
[Aug 04 02:53:10] radvd: sigint_handler called

advertisement appears to fail, since tcpdump ip6 doesn't show them when radvd is
running

Version-Release number of selected component (if applicable):
radvd 0.7.1-1 (rh7.3) till radvd 0.7.2-3 are affected, maybe earlier

How reproducible:
Always

Steps to Reproduce:
1.add AdvSendAdvert on;  in the config file
2.run radvd -u radvd -d 4 -m stderr
3. see the sendmsg error
    

Actual Results:  No advertisement, but computers still can get their v6 by
asking the router at boot time

Expected Results:  adv packets

Additional info:
Comment 1 Need Real Name 2003-08-03 21:00:12 EDT
Created attachment 93369 [details]
my radvd config without the comments
Comment 2 Elliot Lee 2003-08-07 14:20:21 EDT
No such problem here with the exact same config file (I filled in the X's with 0123). I would 
try stracing the process to see why the sendmsg is failing. It's probably not necessary to 
set the MTU like that, but you'll have to track down the problem on your own.

Note You need to log in before you can comment on or make changes to this bug.