Bug 1015655 - [RFE] Change a namespace without first deleting all associated gears
[RFE] Change a namespace without first deleting all associated gears
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks: 1015656
  Show dependency treegraph
 
Reported: 2013-10-04 14:09 EDT by Timothy Williams
Modified: 2015-05-14 20:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1015656 (view as bug list)
Environment:
Last Closed: 2013-10-29 18:28:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy Williams 2013-10-04 14:09:49 EDT
Description of problem:
A request is submitted for the ability to change a namespace with applications already created within the domain. Currently, all applications must be deleted for the namespace to be changed.

In light of this being a rare necessity, it would be acceptable to have to restart all applications when the namespace is created

How reproducible:
Always

Steps to Reproduce:
1. Create a domain
2. Create an application
3. Attempt to change the namespace

Actual results:
"Domain contains applications. Delete applications first before changing the domain namespace."

Expected results:
Domain changed successfully
Comment 1 Abhishek Gupta 2013-10-29 18:28:31 EDT
We have intentionally disabled this feature since we do not have control over how the URL is being handled by the cartridges (namespace is part of the application URL). Cartridges (partner/community cartridges) could hardcode the URL causing the application to break if the namespace is changed. Expecting the cartridges to deal with a namespace/URL change is not feasible and not guaranteed to work.

Please reopen this bug if this is an absolute necessity.

Note You need to log in before you can comment on or make changes to this bug.