Bug 1015669 - Fedora 19 Everything repo sync shows as failed
Fedora 19 Everything repo sync shows as failed
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Justin Sherrill
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 15:25 EDT by Roy Williams
Modified: 2015-12-03 10:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 08:45:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The Pulp log from /var/log/pulp/pulp.log (1.17 MB, application/gzip)
2013-10-04 15:25 EDT, Roy Williams
no flags Details

  None (edit)
Description Roy Williams 2013-10-04 15:25:22 EDT
Created attachment 807905 [details]
The Pulp log from /var/log/pulp/pulp.log

Description of problem:
Katello hangs on repository synchronization when a large repository is synchronized.

Version-Release number of selected component (if applicable):
1.3.30-1.el6

How reproducible:
Everytime

Steps to Reproduce:
1. Add repository from Fedora 19 Everything,
http://dl.fedoraproject.org/pub/fedora/linux/releases/19/Everything/x86_64/os/
2. Synchronize the repository.
3. Wait for the Synchronize task to stall.

Actual results:
Incomplete repository or partial synchronization

Expected results:
A complete synchronization of the repository.
Comment 1 Justin Sherrill 2013-10-07 09:26:53 EDT
I was able to
Comment 2 Justin Sherrill 2013-10-07 09:28:20 EDT
I was able to reproduce this and it appears that it is a problem with the f19 repos.

but it appears the f19 everything repo contains prestodata/drpm metadata but no actual drpms

http://dl.fedoraproject.org/pub/fedora/linux/releases/19/Everything/x86_64/os/
http://dl.fedoraproject.org/pub/fedora/linux/releases/19/Everything/x86_64/os/repodata/ceeda1fb8c827aa12b46c15420de3caeb7d49
e99f45bcc9c72ef70e93bd8bde5-prestodelta.xml.gz


I'm assuming it was included in everything by mistake and was meant to be included only in updates (which contain the drpms)

I've reached out to the fedora group to see about having this corrected.  This shouldn't interfere with the non-drpm syncing of the repo, and it should still be published normally.
Comment 3 Justin Sherrill 2013-10-07 09:58:49 EDT
To clarify, The repository should still work normally, syncs will just show as failed.
Comment 4 Roy Williams 2013-10-07 10:23:47 EDT
Is this something that needs to be addressed with the fedora repository maintainers?
Comment 5 Justin Sherrill 2013-10-07 10:35:25 EDT
Indeed it is, I have filed a ticker here: https://fedorahosted.org/fedora-infrastructure/ticket/4052
Comment 6 Tim Hughes 2013-11-08 09:53:46 EST
Ticket has been closed as wontfix:

https://fedorahosted.org/fedora-infrastructure/ticket/4052#comment:1

Comment is:

this is a side effect of how the Everything repo is made. at this point we cant fix it. yum skips over the missing drpms, pulp should do the same.
Comment 7 Tim Hughes 2013-11-08 10:03:25 EST
Does anyone have a workaround for this ? Can I cancel my "fedora-19-everything-x86_64" sync task and have the "auto_publish, publish" ones continue ?


My current state is:

[root@reposerver ~]# pulp-admin tasks list 
+----------------------------------------------------------------------+
                                 Tasks
+----------------------------------------------------------------------+

Operations:  sync
Resources:   fedora-19-everything-x86_64 (repository)
State:       Running
Start Time:  2013-11-08T14:57:38Z
Finish Time: Incomplete
Result:      Incomplete
Task Id:     50c2f6b1-7393-463c-964f-c46e971a6e66

Operations:  auto_publish, publish
Resources:   fedora-19-everything-x86_64 (repository)
State:       Running
Start Time:  2013-11-08T14:57:38Z
Finish Time: Incomplete
Result:      Incomplete
Task Id:     2371cf18-5de5-402e-aebc-eaa104f8ca75

Operations:  auto_publish, publish
Resources:   fedora-19-os-x86_64 (repository)
State:       Running
Start Time:  2013-11-08T14:57:38Z
Finish Time: Incomplete
Result:      Incomplete
Task Id:     81009bd4-52f8-4348-8bb7-71ff4e6920e4
Comment 8 Bryan Kearney 2014-01-21 14:07:41 EST
Moving to Sat6 to be tracked there. Upstream bugs are moving to redmine.
Comment 9 RHEL Product and Program Management 2014-01-21 14:19:02 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 11 Bryan Kearney 2015-10-13 08:45:00 EDT
This relates to an old Fedora which is no longer supported. If you are seeing this on a newer Fedora, please feel free to re-open.

Note You need to log in before you can comment on or make changes to this bug.