Bug 1015724 - Add maintenance mode to hosted engine agent
Add maintenance mode to hosted engine agent
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Greg Padgett
Artyom
sla
:
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-10-04 19:38 EDT by Greg Padgett
Modified: 2016-06-12 19:16 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-ha-0.1.0-0.5.1.beta1.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:50:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
agent and vdsm logs for local maintenance state (114.64 KB, application/zip)
2013-11-08 01:45 EST, Artyom
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19711 None None None Never
oVirt gerrit 20127 None None None Never
oVirt gerrit 20128 None None None Never
oVirt gerrit 20278 None None None Never
oVirt gerrit 20279 None None None Never

  None (edit)
Description Greg Padgett 2013-10-04 19:38:22 EDT
Maintenance mode is needed in the hosted engine agent to enable admins to work on the engine VM without possible interference from the agent.  This mode will instruct the agent to ignore the engine VM, whether running or not, and to not stop it, start it, or migrate it.

Support will first be added for the agent to recognize a maintenance flag located in block 0 in the shared metadata, as well as a method in the client api allowing the flag to be set by other python programs such as the hosted-engine tool.
Comment 1 Greg Padgett 2013-10-29 09:59:16 EDT
Merged the following:
Change-Id: I796d768e197c5fe73646e67297714392bc6e8201
Change-Id: I60e62cd03daec812e16a3a5bbd2d3d896e41402d
Change-Id: If11d561a39cc9723ffdd55836db693fc2aad0575
Comment 3 Artyom 2013-10-30 12:05:58 EDT
Please provide in what version it included and also how I can to activate maintenance mode?
Comment 4 Doron Fediuck 2013-11-04 23:40:38 EST
(In reply to Artyom from comment #3)
> Please provide in what version it included and also how I can to activate
> maintenance mode?

This will need a new vdsm build, which reports the HA score to the engine.
Comment 5 Sandro Bonazzola 2013-11-05 07:56:59 EST
(In reply to Doron Fediuck from comment #4)
> (In reply to Artyom from comment #3)
> > Please provide in what version it included and also how I can to activate
> > maintenance mode?
> 
> This will need a new vdsm build, which reports the HA score to the engine.

Should be in next build.
Comment 6 Artyom 2013-11-08 01:44:01 EST
Checked on ovirt-hosted-engine-ha-0.1.0-0.5.1.beta1.el6ev.noarch
1) set maintenance mode to local - put engine vm down and also set host score to 0, also I can see in log Local HA maintenance enabled

2) set maintenance mode to global - the same as local, just in log Global HA maintenance enabled

so after enable maintenance mode enabled I can't connect to engine vm(via ssh, it's really in down mode), so I don't think that it desired behavior, how I understand from description.

Also it's not bad to give some more explicit information about states(local, global) and what desired behavior for each state, for correct verification of bug.
Thanks
Comment 7 Artyom 2013-11-08 01:45:16 EST
Created attachment 821436 [details]
agent and vdsm logs for local maintenance state
Comment 8 Greg Padgett 2013-11-08 12:28:20 EST
(In reply to Artyom from comment #6)
> Checked on ovirt-hosted-engine-ha-0.1.0-0.5.1.beta1.el6ev.noarch
> 1) set maintenance mode to local - put engine vm down and also set host
> score to 0, also I can see in log Local HA maintenance enabled

This seems right.

> 2) set maintenance mode to global - the same as local, just in log Global HA
> maintenance enabled
> 
> so after enable maintenance mode enabled I can't connect to engine vm(via
> ssh, it's really in down mode), so I don't think that it desired behavior,
> how I understand from description.

Which maintenance mode?  For local, the vm is expected to go down.  For global, the vm is expected to stay in its current state on its current host (i.e. the user assumes complete control of the vm during global maintenance).

> Also it's not bad to give some more explicit information about states(local,
> global) and what desired behavior for each state, for correct verification
> of bug.
> Thanks

Can you take a look at [1] to see if it answers your questions?  I'll set this bug to modified for now, and we can go from there.  Thanks.

[1] http://www.ovirt.org/Features/Self_Hosted_Engine#Maintenance_Flows
Comment 9 Artyom 2013-11-11 06:49:26 EST
Thank for documentation it was useful, maintenance mode work correct:
1) maintenance local mode - put vm down, and set score of host where vm was to 0, after this ha agent start vm on second host
2) global maintenance mode - vm in up state, but ha not try to migrate or start vm(stoped vm manually), host score stay 2400, after return to maintenance none mode, ha start vm on old host.
So you can change status to on_qa and I will verified it.
Sorry for misunderstanding about local state, I was thinking that maintenance mode need for working on vm without interrupt from ha, but local mode is for working on host.
Comment 10 Greg Padgett 2013-11-11 07:28:42 EST
(In reply to Artyom from comment #9)
> So you can change status to on_qa and I will verified it.

Thanks Artyom!
Comment 11 Artyom 2013-11-11 07:41:00 EST
Verified on ovirt-hosted-engine-ha-0.1.0-0.5.1.beta1.el6ev.noarch
Comment 12 Charlie 2013-11-27 20:42:23 EST
This bug is currently attached to errata RHEA-2013:15591. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 13 Greg Padgett 2013-12-06 12:58:13 EST
ovirt-hosted-engine-ha is a new package; does not need errata for bugs during its development.
Comment 14 errata-xmlrpc 2014-01-21 11:50:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0080.html

Note You need to log in before you can comment on or make changes to this bug.